ODK Build not saving form or uploading to Aggregate

1. What is the problem? Be very detailed.
I have been trying to save my forms in ODK Build (Online Version) and also upload to aggregate without success.
I get an error "Could not save the form. Please try again in a moment." in red caps when I try to save and "Could not upload the form. Please check your credentials and instance name, and try again" when I try to send to aggregate and the credentials are correct.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Build Online Version and ODK Aggregate v2.0.3 on Digital ocean servers

3. What you have you tried to fix the problem?

Tried changing passwords without any success

4. What steps can we take to reproduce the problem?
Create a form in ODK build and try saving

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Hi @AlexKaranja! Thanks for reporting this issue. I've been able to reproduce it and I'm working on a fix.

For now, please do a Save Form to File and an Export to XLSForm so you have two copies of your form design in independent formats.

As to uploading to Aggregate, Export to XML and you should be able to upload that file to Aggregate directly.

@AlexKaranja, I've rolled back the recent changes to Build while I try to track down what went wrong. Can you confirm that everything is working for you now?

@yanokwa I had tried export to XML then tried uploading directly to aggregate but was giving an error.

@yanokwa I confirm its now working.