ODK Central - Enketo Form - Save draft and submission error

Getting error in enketo form while saving the enketo form data as a save draft / submitting in ODK Central. Tried to change the record name / ID but still same error appears.
Referenced error snapshots have been attached for the same. Kindly help.

Thank You!

Welcome, @vishvas.sahni, and I'm sorry you're seeing this error.

What version of Central are you running? There were some known cases in which this would happen in older web form versions but it is unexpected otherwise. It would be helpful to know whether it could be an older version or not.

Thanks for reply.
We are using ODK Central v1.5.2.

We are getting this Enketo error also while uploading the record.
Refered snapshots.

Hello @vishvas.sahni,

Thank you for sharing the version of Central that you are using. As @LN highlighted, there were known issues, and there have been a number of updates since the v1.5.2.

Please consider upgrading central to a more recent release. See the release page here

Thank you.

1 Like

@Neha.khanna has reported something very similar at 409 error while submitting a response. Could it be the same report by any chance?

https://github.com/enketo/enketo-express/issues/416 is the related issue that I had in mind. However, this looks different because it's the server reporting a duplicate. Did anything unusual happen when attempting to send? Have you seen this with multiple submission attempts or just one?

One thing you could try is to click the export button and find out the instanceID of the submission. Then you can look that up in the submission table on Central (using your browser's search, e.g. CTRL+F). You can edit the record from Central to compare the data there and in the exported record. Are they the same or different? Were they from the same person?

Thanks for your valuable input!
We did the following as you described.

  1. Exported the submission.
  2. Extracted the instanceID of the submission.
  3. Checked the existence of this instanceID in submission table on central.
  4. Found the same instanceID which was already exist in submission table.
  5. And finally found the record that was submitted by the same person.
    Kindly suggest!

@LN did you get the chance checked my last message?

I apologize for missing this update. It looks to me like you are using an offline-enabled form and the person filling it out had saved as draft, right? My guess is that they either opened the draft in two tabs or opened the draft right as it was sending. If the data is the same on the server as the exported record, you can ignore this failing submission. If you want it to go away, you can make sure that it is the only record in the queue and then clear your browser cache.

We now have an issue for this problem and hope to address it within the next 3 months or so: https://github.com/enketo/enketo-express/issues/567