ODK Central Enketo Form Server 404 Error

Hi All,

I'm new to installing ODK Central with docker and becoming familiar with setting the system up. I'm deploying the system on a domain with a custom SSL, and have been able to follow the ODK Central document to the point of creating and promoting a user account.

1. What is the problem? Be very detailed.
ODK Central is currently working in docker and all the states are healthy. However, when trying to see the form previews, use ODATA, or see submission forms previewed, I received an error "Something went wrong: the server returned an invalid error." but I am still able to manually download form submissions. I am unable to access Enketo locally and have forwarded traffic from port 5432 to 8001 because my organization's Microsoft Azure (Hyper V) server is being used by several other systems.

2. What app or server are you using and on what device and operating system? Include version numbers.
Currently running ODK Central v1.1.2
Docker version 20.10.5, build 55c4c88
Microsoft Azure Windows Server 2019 Hyper V environment Linux Container

3. What you have you tried to fix the problem?
The currents troubleshooting steps that I've taken have been binding a new port to postgres. Manually installing the back and front end of the server.

4. What steps can we take to reproduce the problem?
The steps to reproduce the error is downloading the git central repository, with a customssl that is composed in docker.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

The error message we're receiving:

Have you tried the steps at https://docs.getodk.org/central-troubleshooting/#preview-could-not-connect-with-server?

Hi @yanokwa,

Thanks for your advice, I was able to get a step further but came across another error:

getaddrinfo ENOTFOUND mydomain

I'm currently searching stackoverflow to understand the error, but any assistance would be helpful. The DNS upstream that my server uses is reddog and I'm not sure if that's the issue.


This is most certainly a DNS issue. You need a fully qualified domain pointing to your server’s IP. Perhaps your IT team can help?

Hi @yanokwa,

I wanted to thank you for your assistance in this matter. You entirely correct, it was a DNS issue and we were able to get this issue resolved by adding a local DNS that pointed to our server's private IP. This issue can be closed.