ODK Central Gmail Emails - Envelop Sender Address is blank

1. What is the problem? Be very detailed.
We are using ODK Central within a large organisation and our Gmail Accounts activation and password reset emails from Central get blocked by the Orgs email server. As such I have to manually forward these emails with my Org email. After discussing with those in control of the email servers I have discovered the emails coming from ODK Central using the Google account don't have an envelop sender attached which should be the same email address used to send and it is instead blank.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Central running on Ubuntu 20.04 v1.3.0 trying to receive emails using Microsoft Exchange email server.

3. What you have you tried to fix the problem?
I have tried adjusting the serviceAccount configuration option to include the full email address instead of the Google username.

4. What steps can we take to reproduce the problem?
Use a Gmail account to send email using SMTP.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
The emails message details show " Envelop Sender: (no sender) "