ODK Central: I have an empty submission

My version is v2023.5.1
1. What is the issue? Please be detailed.
A submmition loaded in ODK-central its completely empty. Our forms are design so no form can be uploaded if certain data is nos filled. The user had the form completed in his phone.

2. What steps can we take to reproduce this issue?
fill a form in odk-collect, send to the server. Check the submmition tables

3. What have you tried to fix the issue?
I checked other forms from thesame user and they are ok. Reboot Android phone. All other forms are ok. The service is flowing. Its just that one.

4. Upload any forms or screenshots you can share publicly below.

Thanks for specifying your Central version, that's very helpful.

Is the row in the submission table completely empty or does it contain some information like submission id? What happens if you hover over the row and click "More"? "Edit"? Do you see any data at all in either of those views?

When you're in the "More" view -- the submission details -- the page address should be something like


If you change the # to v1 and then add .xml to the end of the address, what do you see? This should be the raw submission that was sent from Collect to Central.

Finally, if the submission was not deleted from the Android device, you could try resending using these instructions: https://docs.getodk.org/collect-forms/#sending-previously-sent-forms

Thanks for replying.
The row has only Submitted by, Submitted at, State and actions, Start date, (no end date),username,deviceid, phonenumber and Instance ID.
If I click More I see the screen with the details but no data. The "Edit" command doesn't work for some reason. It never works with any form I have tried.
If I change # to v1 and add .xml to the end it returns the xml version with just the few fields I mentioned at the begining.
I will try to resend the form as you specified.
I will let you know.

Thank you

1 Like