ODK Central installation error

1. What is the issue? Please be detailed.
I am trying to install ODK Central on Digital Ocean, and I am getting this error/message at the end:

failed to solve: process "/bin/sh -c OIDC_ENABLED="$OIDC_ENABLED" files/prebuild/build-frontend.sh" did not complete successfully: exit code: 134

Kindly assist in resolving the problem.


2. What steps can we take to reproduce this issue?
Not sure.

3. What have you tried to fix the issue?
Run the build instructions again

4. Upload any forms or screenshots you can share publicly below.

I see an "out of memory" notice in the log, what is the type and size of your server instance on Digital Ocean?

1 Like

Good day,

I am using a free trial account for a Droplet of 1GB/ 1 vCPU.


You need more RAM to complete the build. Upgrade to a 2 GB machine.

I'll update the docs to make sure others don't run into this issue.


That must be my issue. I have yet been able to complete the installation of ODK on Digital Ocean. I gave up after a dozen tries. I will try again with the 2 GB

It might not be your issue. Look at your logs to see what the likely issue is.

Thanks so much. It worked after upgrading to 2GB.

1 Like