ODK Central Login failure

1. What is the problem? Be very detailed.
I was successful in following the excellent instructions to get ODK central installed on a DigitalOcean Droplet with a DNS registered through GoDaddy. I was able to access the Central instance to upload forms, submit and view data using Chrome, ODK Collect and through R using the ruODK library. I was very pleased because it is so much more functional than Aggregate

After some time working with it today and no configuration changes the central instance abruptly stopped working on all platforms. The login to Central returned the error "Something went wrong: the server returned an invalid error."

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Central on DigitalOcean

3. What you have you tried to fix the problem?

  1. I first logged into the Docker console and docker-compose ps indicated that everything was fine.

  2. I tried creating new users in docker and logging in with those credentials, same error

  3. I restarted docker and it rebooted without any errors or flags, now when I try to login / password, it gives me Incorrect email address and/or password, including when I try to reset password. This continues when I create further new users in Docker

4. What steps can we take to reproduce the problem?
I have no idea

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
I am afraid that I can't offer more information because I don't yet know where to look. It seems that the frontend and backend have become detached, but I can't think of anything thta I could have done to instigate this

Sorry to hear you're having these issues! First, could you please hard refreshing your browser window? This is usually done with something like CTRL/Apple + SHIFT + R. Then try logging in again with your original user. The Central frontend has some weird behavior around sessions and can get into bad states when multiple windows are logged in or different users are used. We have planned fixes for these for the next release.

Hopefully this will get you back to a good state. If your original user is not accessible, you may need to read this help section.

I don't have an explanation for the "invalid error" you ran into originally. You could try docker-compose logs nginx from the central directory to see if you get any hints. An "invalid error" generally means that frontend got an error that wasn't from backend and it often comes from the nginx layer. One other change we have planned for v1.2 is to display the raw "invalid error" so that troubleshooting this kind of state doesn't require going to logs.

1 Like