ODK central not loading after update

1. What is the issue? Please be detailed.
after recent update. ODK Central website not loading collect data. its always on loading loop. can able to login and view the hosted projects but unable to loading the collected data and view the submissions

2. What steps can we take to reproduce this issue?

3. What have you tried to fix the issue?
tried restarting containers but not fixed yet.

4. Upload any forms or screenshots you can share publicly below.

It may be helpful to read the container logs: https://docs.getodk.org/central-troubleshooting/#reading-container-logs

What version of Central was your server before the upgrade?

What version of Central are you running now?

To see your version, click on the question mark icon in the upper right section of your Central menu bar, then click Version. If you don't see the question mark, you can see the version by adding version.txt to the root URL (e.g., demo.getodk.cloud/version.txt).


Thanks for the reply

Version.txt displays

4732f7112a286165241aaf7f971f2c2e38d6bb8a client (v1.0.0)
e9ffd2c0c3aa1a9475852e1397b8259e2b03165a server (v1.0.3)

If you recently upgraded, it appears something went wrong and the upgrade did not succeed. You are running a very outdated version of Central as v1.0.3 is from 2020. I suggest you go through the steps to upgrade your server to the current version (which is v2023.5.1 as of this post). You'll want to be sure to carefully review https://docs.getodk.org/central-upgrade/ and consider all notes and warnings. Review upgrade instructions for all versions between your version and the new version.

1 Like

Is it safe to update now? There is already alot of collected data is there unfortunately we can’t access it now as per shown error. What are safety ways to update/upgrade the system without losing the data. Please suggest

It is recommended that you back up your server before an upgrade. It sounds like you attempted an upgrade already and it failed. It's not clear what the impact of that might have been, and it is unclear about the current state of your server and data.

Did you check you server logs?