ODK Central not loading on DigitalOcean with FreeDNS

1. What is the problem? Be very detailed.
The ODK Central landing page is not loading. Firefox gives me an "Unable to connect" message. It has been over 24h now since I created the subdomain on FreeDNS.

2. What app or server are you using and on what device and operating system? Include version numbers.

  • ODK Central (latest version I guess since the installation was done on Tuesday)
  • DigitalOcean (Ubuntu 20.04.2).
  • Subdomain via FreeDNS

3. What you have you tried to fix the problem?

  • I have double checked that the subdomain is correct in the ODK Central settings using the nano .env command in the DigitalOcean console (XXX.mooo.com).
  • I used the ping command in the Windows console to check the URL. The URL is correctly resolved and points to the correct IP address for the Droplet (
  • I ran the docker-compose ps command again to check the server status. nginx is up (healthy) as it should be.

4. What steps can we take to reproduce the problem?
Since this is a business installation, I could only send the server URL via private message.

I have now switched from a XXX@mooo.com domain to a XXX@dockl.com domain and now it is working.