ODK Central on DigitalOcean Installation

1. What is the problem? Be very detailed.
Install ODK Central on DigitalOcean following this link https://docs.getodk.org/central-install-digital-ocean/#central-install-digital-ocean and the installation went just fine without any errors but when I tried accessing the site using chrome it gave me "ERR_CONNECTION_REFUSED".

2. What app or server are you using and on what device and operating system? Include version numbers.
DigitalOcean Droplet: Docker 19.03.12 on Ubuntu 20.04

3. What you have you tried to fix the problem?
Restarted the server. If you can send me a link on how to troubleshoot the cause so I can fix it.

4. What steps can we take to reproduce the problem?
Don't know.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
Been doing this installation guide several times but still have not found any solution. Looking in the forum that can help me but still have not found any solution. I'm very grateful if someone can just assist me in solving my problem.

Thank you in advance.

I have the same error. I successfully installed ODK Central on DigitalOcean following the tutorial, but I could not access the website in Google Chrome with an error (This site can’t be reached, xxx.com refused to connect.). Could you tell me how to fix this issue?

1 Like

Hi @kazukiming ,
We're glad you're here. When you get a chance, please introduce yourself on this forum thread.

Getting the server up and running is tricky, I've stubbed my toes a good few times on infrastructure and networking.

Tell us:
Have you configured the domain correctly?
Are your containers running? docker-compose ps
What do the logs say? docker-compose logs
Can you find your error(s) in previous posts about ERR_CONNECTION_REFUSED in ODK Central or elsewhere in the forum?

Hi @Florian_May

Thank you for your reply.
I have reinstalled the ODK Central on DigitalOcean and now it is working!

Maybe the problem came from installing ODK Central before the domain was linked to the IP address of the droplet in DigitalOcean. This time I waited for a while and made sure that the domain is linked to IP address before starting to install the ODK Central.

1 Like

Thank you for this information. I have not made it running on my side and installed ODK Aggregate instead. I will definitely try your approach.


Sorry for the late update. Just got back to this one because we need to migrate our servers and thanks to Florian for pushing me to do this. I made it working in DigitalOcean and the problem was with the Docker Compose which I found here. Thanks Yan. Now I can migrate our Aggregate to Central.

1 Like