ODK Central unable to access domain

1. What is the problem? Be very detailed.

Am unable to access server with either the domain name or IP address

2. What app or server are you using and on what device and operating system? Include version numbers.
Digital Ocean droplet -
Docker 19.03.12 on Ubuntu 20.04

3. What you have you tried to fix the problem?

Have tried opening the ports 80 and 443 using ufw and ip tables

4. What steps can we take to reproduce the problem?

Try to login to

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

On running this command “docker-compose up -d”

I get the following errors
ERROR: for nginx Cannot start service nginx: driver failed programming external connectivity on endpoint nginx (42da5bd3208e8a3917788c91f2c49a7808bb4cce92aacaaec3ec09fdd33fe44b): Error starting userland proxy: listen tcp bind: address already in use

ERROR: Encountered errors while bringing up the project.

1 Like

@vnatraj The reason is that the port 80 is occupied by nginx on the host machine itself. When you are trying to run the docker, port 80 conflict is happening. So run the following command on the host machine:
sudo service nginx stop

Once you have run the above command, try running the command to bring the docker up. Please do share the findings.

Thank you very much.

I ran the command to stop nginx and the command to bring docker up. ODK Central loads on the domain URL.