ODK Central Upgrade to 1.2.1 - Project pages could not be loaded

1. What is the problem? Be very detailed.

I have upgraded ODK Central to v1.2.1 and when testing whether the upgrade has worked, I have found an error when attempting to view Project Roles, App Users and Form Access pages under each project. I get an error stating "The page you requested could not be loaded. Please check that you are online and try again". I can confirm I am online. I have tested this under each of the Projects within our instance, and the same error appears each time. I cannot view or edit any existing forms within a Project, add or amend app users, or amend Form Access. For now I have rolled back my virtual machine so it is back to a snapshot prior to upgrading. But need urgent assistance to resolve this.

2. What app or server are you using and on what device and operating system? Include version numbers.

ODK Central v.1.2.1. Operating system Ubuntu 20.04.

3. What you have you tried to fix the problem?

Nothing yet as I don't know how to proceed.

4. What steps can we take to reproduce the problem?


5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Hi @andybennett! I think this might be the same issue as the one below. What happens if you refresh the page?

1 Like

Hu @Matthew_White. The fix in the thread you mentioned has worked. Clearing browser cache removed the error. Many thanks!!