ODK Central Upgrade - Version not updating

1. What is the problem? Be very detailed.

I have recently upgraded my ODK Central to the latest version (which should be v1.3.3). I have followed the online guidance; git pull, git submodule update -i, docker-compose build, docker-compose up -d etc. When I run git submodule update -i nothing appears to update. And subsequently when I bring the docker containers up again, the version.txt file still shows the old version number; v1.2.1. I have tried to hard refresh my browser in case of any caching. It simply looks like the upgrade has not worked.

2. What app or server are you using and on what device and operating system? Include version numbers.

Tried to upgrade from Central 1.2.1 to 1.3.3. Docker compose version is v2.2.3. Operating system is Ubuntu 20.04.

3. What you have you tried to fix the problem?

Run the upgrade process as per online documentation twice.

4. What steps can we take to reproduce the problem?


5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Can update thread with any logs as required.

Hi @andybennett,

did you read the instructions below?


Hi @aurdipas,

Yes before I upgraded I ran the docker-compose update. The version of docker-compose now used is v2.2.3.

I suspect the issue is with the git submodule update -i command, because when I run command, nothing appears to update. I cannot seem to get the latest client and server versions.

This might be outside of this forum's support, but if any help can be provided I would appreciate.


can you execute the folloiwing?

docker-compose -v

if you did as indicated in the docs you should have

docker-compose version 1.29.2


Output as below:

Docker Compose version v2.2.3

At my organisation, we have a script to maintain Docker and Docker Compose to the latest versions.

Should I downgrade Compose version to 1.29.2?


Not sure if this is the problem.
The current stable release of Docker Compose:is 1.29.2, and I believe is the version the latest central was tested/developed.

Maybe better to ask @yanokwa the docker guru :slight_smile:

To ensure I am using the version as advised, I will downgrade the docker compose version to 1.29.2 and try to rebuild the containers again.

Thank you

There shouldn't be any issue with the Docker version, but to guarantee that it's not, I would downgrade to v1.29.2

Run git log and git status and post the results of each. That will confirm if you have the right versions.

Next make sure you are stopping the container. I usually do it in one go.
docker-compose build && docker-compose stop && docker-compose up --detach

1 Like