ODK Collect 1.12.1 stops when logging in to get blank form

The app starts to log in (I give username and pwd); server is set to appropriate server (kc.kobotoolbox.org)

before it can display available forms, it shuts down, and offers reporting (through google, I think) and also restarting the app.

I think the login info is OK because if I deliberately change to the wrong pwd it doesn't get that far and says the login info is incorrect.

Could this be an issue with the form hub or particular form hubs? I think it happens at ona.io with a survey we have there as well.

This is on an Android phone. Now trying a restart of phone.

thanks, Steve

What ODK tool and version are you using? And on what device and operating system version?

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

1 Like

Hi @sjvanek, thanks for filing this issue! We are seeing these crashes, but we can't reproduce them. We think that the Formhub-derived servers may not be sending the information we expect?

We just shipped an update to Collect a few minute ago (v1.12.2) that might help, so upgrade to that and report back. Also, I'm curious are any of the blank forms you are trying to list have media attachments?

Thanks for reporting this, @sjvanek, as @yanokwa said it does seem related to mysterious crashes we've been seeing. I just tried a form with jpg attachments served from Ona on 1.12.0 and form listing worked without problems.

@sjvanek Please share any info you can about your form. How was it created? Was that form ever on your device? Did you make changes to the form and re-upload it? What is the form ID?


I'm a colleague of @sjvanek, exploring the same issue. I've just updated to ODK Collect v1.12.2, and am happy to report that appears to have fixed the crash - at least on my side.

For info: I'd discovered that the crash only seemed to occur when I already had one or more blank forms downloaded to the phone. If I had no blank forms, Get Blank Form worked as expected, but if I had any blank forms already downloaded, Get Blank Form would cause a crash. It didn't seem to matter whether the downloaded form had media attachments or not.

Thanks both, and hopefully what-ever you did for the new version has fully resolved the issue.

~ D.

1 Like

Thanks for that update, @degami! I'm glad to know it's looking like it's fixed. Please update us if you see any other issues.

What you're describing makes sense -- the crash was in code to identify new versions of forms.

I am now able to reproduce in 1.12.0 by downloading a form from Ona and then getting blank forms. Previously I had an update to an existing form but that one had been downloaded from Aggregate. I'll look further into what the root cause is.

UPDATE: Formhub-derived servers don't send the version in the formList as described in https://docs.opendatakit.org/openrosa-form-list/#successful-response-document. The current fix avoids a crash but means updates to media files for forms that have a version defined won't be detected.

Hi, yes, the 1.12.2 update resolve it. Even if I already have other forms dowloaded. Thanks. this was on a motorola nexus 6 running android 7.0, if that helps.

1 Like

A post was split to a new topic: Run Collect with Android "spying" app