ODK Collect - empty instance folder

What is the problem? Please be detailed.
hi all, I have a simple repeat group form that asks for a few text details along with a photograph. In essence it's just a simple photolog.

I have now had an issue twice where my users say they take multiple photos and write down a description (this is a simple repeat, where they are asked "Add new group?" if they want to take another photo. As soon as they finish the last photo the form ends). However, back in the office, that instance folder is in the instances\ directory but it's completely blank. No XML file, no photos, nothing. I've even tried zipping it up to make sure nothing is hidden. This is the same user, so I suspect they are doing something wrong. This form usually works flawlessly. Has anyone encountered this issue before?

What ODK tool and version are you using? And on what device and operating system version?
ODk Collect 1.18.0 on a Samsung Galaxy Tab S10 with Android 6.0.

My normal workflow is just to zip all of these instance folders (with the photos and XML) and reformat the XML as an Excel file with all of the photo attributes. I am not using an Aggregate server.

Hi @Gunn777,

I have never encountered this issue before. It is like the data don't get saved at all. Those instances are the data, if empty means no data was saved. I have a question for you. Is the number of forms entered shown in the main menu? Edit form or send finalized? Where exactly?

Are you able to browse the form data in the device? It is true they might be doing something wrong eg failing to save or failing to enter. Try to confirm the forms instances in the devices first.

Hi @dicksonsamwel

Thanks for the response. To answer your question, the instance in question does not show up in any location in the ODK main menu -- edit saved form, send finalized form, or delete saved form. The only location where I see the instance is in the odk\instances\ folder on the device file system. In this case, it's just an empty folder.

So the count of folders in odk\instances\ is one more than the count given in the menu at "Edit saved form." It's as if it doesn't recognize it.

I suspect that they might have started a new form, but maybe tried to exit without filling anything out and hit "Ignore changes." I'll try to reproduce this scenario.

Hi Dickson,

So I was just able to reproduce the problem. I can start a new form, type in my required text information, and proceed through 2 (I could probably do more than 2) repeat question groups and take photos. If I don't hit save at any point, and I leave the form and press "ignore changes" it creates an empty instance folder on the device but it does not show up in edit saved forms, etc.

I was under the impression that ODK saved the form automatically as we proceed (swipe) through questions. Is there any way I can force this autosave, or hide the "ignore changes" option? Thanks.

Hi @Gunn777,

Am glad you were able to reproduce the issue.

The autosave feature is not available at the moment. The ignore changes can't be hidden as well.

One thing I can advice is to instruct the data collector to save the data occasionally by pressing the save button at the top (save icon). And never to ignore changes, always to save them. Even if you are not using the aggregate, i think it is also important to save the form and mark them as finalized. Then later you can cross-check them before manually pulling them.

1 Like

Thanks, Dickson. It's unfortunate that the autosave feature is not working at the moment. I try to stress to my users that they need to hit the save button frequently, but I think after long days in the field they sometimes tend to forget.

I have not read much about ODK2. Do you know if the form saving is handled differently in ODK2?

Thanks too.

Am not much aware of ODK2 at the moment, am still reading it.