ODK Collect Failing Submission after SSL Installation

1. What is the problem? Be very detailed.
I recently installed SSL Certificate on my server. I tested access via the web and its working fine. However the tablets are failing to Sync showing the error below:


I have tested my SSL via the link https://www.sslshopper.com/ssl-checker.html and getting all green ticks on everything

2. What app or server are you using and on what device and operating system? Include version numbers.
Running ODK Aggregate 2.02

3. What you have you tried to fix the problem?
Removed the SSL Certificate and it worked so I am certain its the SSL Certificate. All the necessary ports have been allowed through Firewall.

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Please note that Aggregate is no longer being supported. Central is now the ODK server. The post below has for more details about the end-of-life for Aggregate.

Someone on the forum may still be able to help you. Is this a local installation? Or on a cloud-services provider?

Local installation. Would appreciate any support.

Look at your Tomcat logs for hints as to what is happening.

1 Like