ODK Collect forms are not uploading to Google Sheets despite indicating "success"

1. What is the problem? Be very detailed.
For some reason, even though when I selected "Send Finalized Form" in ODK Collect and it indicates the form was sent successfully - the data entries don't show up in the linked Google Sheets. Everything was working fine on Monday and Tuesday (6/28 and 6/29), but all our data entries from the rest of the week never uploaded.

2. What app or server are you using and on what device and operating system? Include version numbers.

Using ODK Collect and a Google Drive/Sheet server. I am using a Samsung Galaxy tab active 2 - Android.

3. What you have you tried to fix the problem?

I have tried multiple things - I made a copy of the datasheet I was using and deleted all 250 of the entries - so it's blank. I changed the submission url to match the new datasheet and then uploaded this new blank form to my tablet. It still says it's succefully uploaded the datasheets but I can't find them anywhere.

4. What steps can we take to reproduce the problem?


5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.