ODK Collect showing wrong IP address while uploading

ODK Collect is giving an error while sending the finalized form. It is giving an error as Forbidden 403 at
My server address is not this but still it shows but my server address is 137.....why is it referring to some other IP ? and not uploading the filled form?

Que versión de odk utilizas ? Es una vm o estas usando un servidor Tomcat para desplegarla.?

I am using the Collect v1.25.1.
Sever is Central loaded on Digital Ocean.

Hi there, have you tried adding https:// ....this could also stem from the fact that you might have been testing the server on the 185 (which might had been a local IP) or the 137 has been taken by some other device.

1 Like

I am using the Central server which uses the QR for server base authentication and so the address is taken automatically... is also a Digital Ocean address, maybe you have multiple ones attached? For example the default one + a floating IP?

If the server is listening on all interfaces ( it might show different IP in returned messages than the one you use to connect.

What's your full ip address? Can you paste outputs of

  • ip a or ifconfig -a
  • netstat -ltnp
    from your server? Also apache/nginx config if you're using those.

Hi thanks for the response. I figured out the issue. This IP address was inside the Form .XML file which I created using the build option. Unfortunately
the old IP address got into the File when I tried to upload the form directly from the Build Form app.

Thanks again. Have a great year 2020!

1 Like