ODK Korean support

Hi everyone,

I am running a research with ODK in English and planning on running a
parallel study in Korean. I have input items in Korean onto the excel file
that I have used for the current study and changed the default
language into Korean on the setting sheet. But I only could find errors
when I tried to convert it into xml file using the form converter. So far,
I haven't found Korean support. Will anybody let me know if there is a
Korean support or how to create a ODK survey in Korean in case there is no
Korean support yet?

I am not sure what you are asking for.

The standard development cycle is to
(1) define your form in XLS,
(2) run XLSForm to convert it to an XML file, then
(3) place that on your device (copying it over to it via the media device
mounting to the PC or Mac), and perhaps using OI File Manager on the device
to move it into the correct location.
(4) run ODK Collect, open the form, and set the language to your language
choice.
(5) review and make note of any corrections, and repeat.

Are you having problems with any of these steps?

The ODK Collect application screens themselves do not yet have a Korean
translation. We rely on community members to provide those. To provide a
Korean translation for those screens, sign up on Transifex and request to
add a Korean translation to the ODK Collect project
https://www.transifex.com/projects/p/odk-collect/

It will take a day or two for us to accept and add the Korean translation
tab, after which you can go there and provide translations. Let us know
when you have a candidate set of translations, and we can do a custom build
of ODK Collect for you to test with. We are planning on doing a minor ODK
Collect release in November (mostly translation updates and an update to
the protocols for the Google Map Engine publisher).

··· On Tue, Oct 28, 2014 at 9:22 PM, Sojung Kim wrote:

Hi everyone,

I am running a research with ODK in English and planning on running a
parallel study in Korean. I have input items in Korean onto the excel file
that I have used for the current study and changed the default
language into Korean on the setting sheet. But I only could find errors
when I tried to convert it into xml file using the form converter. So far,
I haven't found Korean support. Will anybody let me know if there is a
Korean support or how to create a ODK survey in Korean in case there is no
Korean support yet?

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thank you, Mitch.

Actually, I faced problem on state 2. I defined my form in XLS using Korean
for name, label and appearance on the survey sheet. And I put Korean in the
default_language on the settings sheet. I tried to convert it into an XML
file but I could this error message. Does this mean that the ascii codec
cannot understand my Korean input? Or are there any other issues?
Thank you for your help in advance!

2014년 10월 29일 수요일 오후 12시 38분 42초 UTC-4, Mitch Sundt 님의 말:

··· > I am not sure what you are asking for. > > The standard development cycle is to > (1) define your form in XLS, > (2) run XLSForm to convert it to an XML file, then > (3) place that on your device (copying it over to it via the media device > mounting to the PC or Mac), and perhaps using OI File Manager on the device > to move it into the correct location. > (4) run ODK Collect, open the form, and set the language to your language > choice. > (5) review and make note of any corrections, and repeat. > > Are you having problems with any of these steps? > > The ODK Collect application screens themselves do not yet have a Korean > translation. We rely on community members to provide those. To provide a > Korean translation for those screens, sign up on Transifex and request to > add a Korean translation to the ODK Collect project > https://www.transifex.com/projects/p/odk-collect/ > > It will take a day or two for us to accept and add the Korean translation > tab, after which you can go there and provide translations. Let us know > when you have a candidate set of translations, and we can do a custom build > of ODK Collect for you to test with. We are planning on doing a minor ODK > Collect release in November (mostly translation updates and an update to > the protocols for the Google Map Engine publisher). > > > > > On Tue, Oct 28, 2014 at 9:22 PM, Sojung Kim <sojun...@gmail.com > wrote: > >> Hi everyone, >> >> I am running a research with ODK in English and planning on running a >> parallel study in Korean. I have input items in Korean onto the excel file >> that I have used for the current study and changed the default >> language into Korean on the setting sheet. But I only could find errors >> when I tried to convert it into xml file using the form converter. So far, >> I haven't found Korean support. Will anybody let me know if there is a >> Korean support or how to create a ODK survey in Korean in case there is no >> Korean support yet? >> >> -- >> -- >> Post: opend...@googlegroups.com >> Unsubscribe: opendatakit...@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> >> --- >> You received this message because you are subscribed to the Google Groups >> "ODK Community" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to opendatakit...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com >

See the attached.

When you set the default_language, you need to also ensure that you have
"label::Korean" and "hint::Korean" columns defined.

This also specifies label::English instead of just label so that the
language choices (available in the overflow menu when you are within the
form) will show "English" and "Korean" as the two language choices.

korean_xlsform.xls (24 KB)

··· On Wed, Oct 29, 2014 at 10:22 AM, Sojung Kim wrote:

Thank you, Mitch.

Actually, I faced problem on state 2. I defined my form in XLS using
Korean for name, label and appearance on the survey sheet. And I put Korean
in the default_language on the settings sheet. I tried to convert it into
an XML file but I could this error message. Does this mean that the ascii
codec cannot understand my Korean input? Or are there any other issues?
Thank you for your help in advance!

2014년 10월 29일 수요일 오후 12시 38분 42초 UTC-4, Mitch Sundt 님의 말:

I am not sure what you are asking for.

The standard development cycle is to
(1) define your form in XLS,
(2) run XLSForm to convert it to an XML file, then
(3) place that on your device (copying it over to it via the media device
mounting to the PC or Mac), and perhaps using OI File Manager on the device
to move it into the correct location.
(4) run ODK Collect, open the form, and set the language to your language
choice.
(5) review and make note of any corrections, and repeat.

Are you having problems with any of these steps?

The ODK Collect application screens themselves do not yet have a Korean
translation. We rely on community members to provide those. To provide a
Korean translation for those screens, sign up on Transifex and request to
add a Korean translation to the ODK Collect project
https://www.transifex.com/projects/p/odk-collect/

It will take a day or two for us to accept and add the Korean translation
tab, after which you can go there and provide translations. Let us know
when you have a candidate set of translations, and we can do a custom build
of ODK Collect for you to test with. We are planning on doing a minor ODK
Collect release in November (mostly translation updates and an update to
the protocols for the Google Map Engine publisher).

On Tue, Oct 28, 2014 at 9:22 PM, Sojung Kim sojun...@gmail.com wrote:

Hi everyone,

I am running a research with ODK in English and planning on running a
parallel study in Korean. I have input items in Korean onto the excel file
that I have used for the current study and changed the default
language into Korean on the setting sheet. But I only could find errors
when I tried to convert it into xml file using the form converter. So far,
I haven't found Korean support. Will anybody let me know if there is a
Korean support or how to create a ODK survey in Korean in case there is no
Korean support yet?

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thank you so much, Mitch. I could convert my xls file into xml file
successfully with your help. For one additional question, I have been using
slider function and it is not working this time.
On the items that I use slider, I could see "Slider Widget had invalid
syntax. Should be appearance=slider: minimumNumber:
maximumNumber.........." instead of sliders.
I input on the first row of the survey sheet as "appearance::English" and
on the next cell "appearance::Korean" and kept the correct structure.
I attached the file that I used as a reference.

2014년 10월 29일 수요일 오후 1시 49분 20초 UTC-4, Mitch Sundt 님의 말:

example_EK.xlsx (16.8 KB)

··· > > See the attached. > > When you set the default_language, you need to also ensure that you have > "label::Korean" and "hint::Korean" columns defined. > > This also specifies label::English instead of just label so that the > language choices (available in the overflow menu when you are within the > form) will show "English" and "Korean" as the two language choices. > > > > On Wed, Oct 29, 2014 at 10:22 AM, Sojung Kim <sojun...@gmail.com > wrote: > >> Thank you, Mitch. >> >> Actually, I faced problem on state 2. I defined my form in XLS using >> Korean for name, label and appearance on the survey sheet. And I put Korean >> in the default_language on the settings sheet. I tried to convert it into >> an XML file but I could this error message. Does this mean that the ascii >> codec cannot understand my Korean input? Or are there any other issues? >> Thank you for your help in advance! >> >> >> 2014년 10월 29일 수요일 오후 12시 38분 42초 UTC-4, Mitch Sundt 님의 말: >> >>> I am not sure what you are asking for. >>> >>> The standard development cycle is to >>> (1) define your form in XLS, >>> (2) run XLSForm to convert it to an XML file, then >>> (3) place that on your device (copying it over to it via the media >>> device mounting to the PC or Mac), and perhaps using OI File Manager on the >>> device to move it into the correct location. >>> (4) run ODK Collect, open the form, and set the language to your >>> language choice. >>> (5) review and make note of any corrections, and repeat. >>> >>> Are you having problems with any of these steps? >>> >>> The ODK Collect application screens themselves do not yet have a Korean >>> translation. We rely on community members to provide those. To provide a >>> Korean translation for those screens, sign up on Transifex and request to >>> add a Korean translation to the ODK Collect project >>> https://www.transifex.com/projects/p/odk-collect/ >>> >>> It will take a day or two for us to accept and add the Korean >>> translation tab, after which you can go there and provide translations. Let >>> us know when you have a candidate set of translations, and we can do a >>> custom build of ODK Collect for you to test with. We are planning on doing >>> a minor ODK Collect release in November (mostly translation updates and an >>> update to the protocols for the Google Map Engine publisher). >>> >>> >>> >>> >>> On Tue, Oct 28, 2014 at 9:22 PM, Sojung Kim wrote: >>> >>>> Hi everyone, >>>> >>>> I am running a research with ODK in English and planning on running a >>>> parallel study in Korean. I have input items in Korean onto the excel file >>>> that I have used for the current study and changed the default >>>> language into Korean on the setting sheet. But I only could find errors >>>> when I tried to convert it into xml file using the form converter. So far, >>>> I haven't found Korean support. Will anybody let me know if there is a >>>> Korean support or how to create a ODK survey in Korean in case there is no >>>> Korean support yet? >>>> >>>> -- >>>> -- >>>> Post: opend...@googlegroups.com >>>> Unsubscribe: opendatakit...@googlegroups.com >>>> Options: http://groups.google.com/group/opendatakit?hl=en >>>> >>>> --- >>>> You received this message because you are subscribed to the Google >>>> Groups "ODK Community" group. >>>> To unsubscribe from this group and stop receiving emails from it, send >>>> an email to opendatakit...@googlegroups.com. >>>> For more options, visit https://groups.google.com/d/optout. >>>> >>> >>> >>> >>> -- >>> Mitch Sundt >>> Software Engineer >>> University of Washington >>> mitche...@gmail.com >>> >> -- >> -- >> Post: opend...@googlegroups.com >> Unsubscribe: opendatakit...@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> >> --- >> You received this message because you are subscribed to the Google Groups >> "ODK Community" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to opendatakit...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com >

Don't know about the slider widget; that is not available in ODK Collect.

··· On Wed, Oct 29, 2014 at 2:00 PM, Sojung Kim wrote:

Thank you so much, Mitch. I could convert my xls file into xml file
successfully with your help. For one additional question, I have been using
slider function and it is not working this time.
On the items that I use slider, I could see "Slider Widget had invalid
syntax. Should be appearance=slider: minimumNumber:
maximumNumber.........." instead of sliders.
I input on the first row of the survey sheet as "appearance::English" and
on the next cell "appearance::Korean" and kept the correct structure.
I attached the file that I used as a reference.

2014년 10월 29일 수요일 오후 1시 49분 20초 UTC-4, Mitch Sundt 님의 말:

See the attached.

When you set the default_language, you need to also ensure that you have
"label::Korean" and "hint::Korean" columns defined.

This also specifies label::English instead of just label so that the
language choices (available in the overflow menu when you are within the
form) will show "English" and "Korean" as the two language choices.

On Wed, Oct 29, 2014 at 10:22 AM, Sojung Kim sojun...@gmail.com wrote:

Thank you, Mitch.

Actually, I faced problem on state 2. I defined my form in XLS using
Korean for name, label and appearance on the survey sheet. And I put Korean
in the default_language on the settings sheet. I tried to convert it into
an XML file but I could this error message. Does this mean that the ascii
codec cannot understand my Korean input? Or are there any other issues?
Thank you for your help in advance!

2014년 10월 29일 수요일 오후 12시 38분 42초 UTC-4, Mitch Sundt 님의 말:

I am not sure what you are asking for.

The standard development cycle is to
(1) define your form in XLS,
(2) run XLSForm to convert it to an XML file, then
(3) place that on your device (copying it over to it via the media
device mounting to the PC or Mac), and perhaps using OI File Manager on the
device to move it into the correct location.
(4) run ODK Collect, open the form, and set the language to your
language choice.
(5) review and make note of any corrections, and repeat.

Are you having problems with any of these steps?

The ODK Collect application screens themselves do not yet have a Korean
translation. We rely on community members to provide those. To provide a
Korean translation for those screens, sign up on Transifex and request to
add a Korean translation to the ODK Collect project
https://www.transifex.com/projects/p/odk-collect/

It will take a day or two for us to accept and add the Korean
translation tab, after which you can go there and provide translations. Let
us know when you have a candidate set of translations, and we can do a
custom build of ODK Collect for you to test with. We are planning on doing
a minor ODK Collect release in November (mostly translation updates and an
update to the protocols for the Google Map Engine publisher).

On Tue, Oct 28, 2014 at 9:22 PM, Sojung Kim sojun...@gmail.com wrote:

Hi everyone,

I am running a research with ODK in English and planning on running a
parallel study in Korean. I have input items in Korean onto the excel file
that I have used for the current study and changed the default
language into Korean on the setting sheet. But I only could find errors
when I tried to convert it into xml file using the form converter. So far,
I haven't found Korean support. Will anybody let me know if there is a
Korean support or how to create a ODK survey in Korean in case there is no
Korean support yet?

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thank you anyway!!

2014년 10월 30일 목요일 오후 1시 3분 11초 UTC-4, Mitch Sundt 님의 말:

··· > > Don't know about the slider widget; that is not available in ODK Collect. > > On Wed, Oct 29, 2014 at 2:00 PM, Sojung Kim <sojun...@gmail.com > wrote: > >> Thank you so much, Mitch. I could convert my xls file into xml file >> successfully with your help. For one additional question, I have been using >> slider function and it is not working this time. >> On the items that I use slider, I could see "Slider Widget had invalid >> syntax. Should be appearance=slider: minimumNumber: >> maximumNumber.........." instead of sliders. >> I input on the first row of the survey sheet as "appearance::English" and >> on the next cell "appearance::Korean" and kept the correct structure. >> I attached the file that I used as a reference. >> >> 2014년 10월 29일 수요일 오후 1시 49분 20초 UTC-4, Mitch Sundt 님의 말: >>> >>> See the attached. >>> >>> When you set the default_language, you need to also ensure that you have >>> "label::Korean" and "hint::Korean" columns defined. >>> >>> This also specifies label::English instead of just label so that the >>> language choices (available in the overflow menu when you are within the >>> form) will show "English" and "Korean" as the two language choices. >>> >>> >>> >>> On Wed, Oct 29, 2014 at 10:22 AM, Sojung Kim wrote: >>> >>>> Thank you, Mitch. >>>> >>>> Actually, I faced problem on state 2. I defined my form in XLS using >>>> Korean for name, label and appearance on the survey sheet. And I put Korean >>>> in the default_language on the settings sheet. I tried to convert it into >>>> an XML file but I could this error message. Does this mean that the ascii >>>> codec cannot understand my Korean input? Or are there any other issues? >>>> Thank you for your help in advance! >>>> >>>> >>>> 2014년 10월 29일 수요일 오후 12시 38분 42초 UTC-4, Mitch Sundt 님의 말: >>>> >>>>> I am not sure what you are asking for. >>>>> >>>>> The standard development cycle is to >>>>> (1) define your form in XLS, >>>>> (2) run XLSForm to convert it to an XML file, then >>>>> (3) place that on your device (copying it over to it via the media >>>>> device mounting to the PC or Mac), and perhaps using OI File Manager on the >>>>> device to move it into the correct location. >>>>> (4) run ODK Collect, open the form, and set the language to your >>>>> language choice. >>>>> (5) review and make note of any corrections, and repeat. >>>>> >>>>> Are you having problems with any of these steps? >>>>> >>>>> The ODK Collect application screens themselves do not yet have a >>>>> Korean translation. We rely on community members to provide those. To >>>>> provide a Korean translation for those screens, sign up on Transifex and >>>>> request to add a Korean translation to the ODK Collect project >>>>> https://www.transifex.com/projects/p/odk-collect/ >>>>> >>>>> It will take a day or two for us to accept and add the Korean >>>>> translation tab, after which you can go there and provide translations. Let >>>>> us know when you have a candidate set of translations, and we can do a >>>>> custom build of ODK Collect for you to test with. We are planning on doing >>>>> a minor ODK Collect release in November (mostly translation updates and an >>>>> update to the protocols for the Google Map Engine publisher). >>>>> >>>>> >>>>> >>>>> >>>>> On Tue, Oct 28, 2014 at 9:22 PM, Sojung Kim wrote: >>>>> >>>>>> Hi everyone, >>>>>> >>>>>> I am running a research with ODK in English and planning on running a >>>>>> parallel study in Korean. I have input items in Korean onto the excel file >>>>>> that I have used for the current study and changed the default >>>>>> language into Korean on the setting sheet. But I only could find errors >>>>>> when I tried to convert it into xml file using the form converter. So far, >>>>>> I haven't found Korean support. Will anybody let me know if there is a >>>>>> Korean support or how to create a ODK survey in Korean in case there is no >>>>>> Korean support yet? >>>>>> >>>>>> -- >>>>>> -- >>>>>> Post: opend...@googlegroups.com >>>>>> Unsubscribe: opendatakit...@googlegroups.com >>>>>> Options: http://groups.google.com/group/opendatakit?hl=en >>>>>> >>>>>> --- >>>>>> You received this message because you are subscribed to the Google >>>>>> Groups "ODK Community" group. >>>>>> To unsubscribe from this group and stop receiving emails from it, >>>>>> send an email to opendatakit...@googlegroups.com. >>>>>> For more options, visit https://groups.google.com/d/optout. >>>>>> >>>>> >>>>> >>>>> >>>>> -- >>>>> Mitch Sundt >>>>> Software Engineer >>>>> University of Washington >>>>> mitche...@gmail.com >>>>> >>>> -- >>>> -- >>>> Post: opend...@googlegroups.com >>>> Unsubscribe: opendatakit...@googlegroups.com >>>> Options: http://groups.google.com/group/opendatakit?hl=en >>>> >>>> --- >>>> You received this message because you are subscribed to the Google >>>> Groups "ODK Community" group. >>>> To unsubscribe from this group and stop receiving emails from it, send >>>> an email to opendatakit...@googlegroups.com. >>>> For more options, visit https://groups.google.com/d/optout. >>>> >>> >>> >>> >>> -- >>> Mitch Sundt >>> Software Engineer >>> University of Washington >>> mitche...@gmail.com >>> >> -- >> -- >> Post: opend...@googlegroups.com >> Unsubscribe: opendatakit...@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> >> --- >> You received this message because you are subscribed to the Google Groups >> "ODK Community" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to opendatakit...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com >