ODK Project and Android SDK version

I just want a little sanity check. I've noticed an error when setting
up my ODK project. If I check the AndroidManifest.xml file, I see the
following :

SDK version 3 is Android SDK 1.5. This, setting indicates that ODK
should be written with compliance to Android SDK version 1.5, however,
if I set my project build target to version 1.5 I see a few errors
including

In FormEntryActivity on lines 534, 542, and 176 the use of a
constructor for BitmapDrawable which was not supported until SDK
Version 5, AKA Android SDK 2.0, found here :

http://developer.android.com/reference/android/graphics/drawable/BitmapDrawable.html#BitmapDrawable(android.content.res.Resources,
java.lang.String)

In AudioButton line 43, the use of a method from the Bitmap class not
available until SDK Version 4, AKA Android SDK 1.6
http://developer.android.com/reference/android/graphics/Bitmap.html#getScaledWidth(android.util.DisplayMetrics)

I'd just like to get some clarification on the SDK version to use
Best Regards,
Gary

I am not the expert on this so I assume someone will correct me if I am wrong.

I believe we are moving to the updating min sdk version to 1.6. A
change to the repo on October 22nd shows for version 1.1.5 of Collect
shows the change in the min sdk.(SDK version 4). Here is a link.

http://code.google.com/p/opendatakit/source/diff?spec=svn.collect.649ff570353a929928cd437f7e5b02dac283c6cb&repo=collect&r=649ff570353a929928cd437f7e5b02dac283c6cb&format=side&path=/AndroidManifest.xml

However, the default branch still has the older sdk set to version 3.
I don't think the changes for the 1.1.5 release have migrated back to
the default branch.

Sorry about the confusion.

Cheers,
Waylon

··· On Sun, Oct 24, 2010 at 1:30 PM, Gary Hendrick wrote: > I just want a little sanity check. I've noticed an error when setting > up my ODK project. If I check the AndroidManifest.xml file, I see the > following : > > > > SDK version 3 is Android SDK 1.5. This, setting indicates that ODK > should be written with compliance to Android SDK version 1.5, however, > if I set my project build target to version 1.5 I see a few errors > including > > In FormEntryActivity on lines 534, 542, and 176 the use of a > constructor for BitmapDrawable which was not supported until SDK > Version 5, AKA Android SDK 2.0, found here : > > http://developer.android.com/reference/android/graphics/drawable/BitmapDrawable.html#BitmapDrawable(android.content.res.Resources, > java.lang.String) > > In AudioButton line 43, the use of a method from the Bitmap class not > available until SDK Version 4, AKA Android SDK 1.6 > http://developer.android.com/reference/android/graphics/Bitmap.html#getScaledWidth(android.util.DisplayMetrics) > > I'd just like to get some clarification on the SDK version to use > Best Regards, > Gary > > -- > Post: opendatakit@googlegroups.com > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > Options: http://groups.google.com/group/opendatakit?hl=en >

Thanks Waylon. Any idea about the other problem ? This is the use of
BitMapDrawable constructors in the latest that require Android SDK
2.0.
Regards,
Gary

··· On Oct 24, 5:01 pm, "W. Brunette" wrote: > I am not the expert on this so I assume someone will correct me if I am wrong. > > I believe we are moving to the updating min sdk version to 1.6. A > change to the repo on October 22nd shows for version 1.1.5 of Collect > shows the change in the min sdk.(SDK version 4). Here is a link. > > http://code.google.com/p/opendatakit/source/diff?spec=svn.collect.649... > > However, the default branch still has the older sdk set to version 3. > I don't think the changes for the 1.1.5 release have migrated back to > the default branch. > > Sorry about the confusion. > > Cheers, > Waylon > > > > > > > > On Sun, Oct 24, 2010 at 1:30 PM, Gary Hendrick wrote: > > I just want a little sanity check. I've noticed an error when setting > > up my ODK project. If I check the AndroidManifest.xml file, I see the > > following : > > > > > > SDK version 3 is Android SDK 1.5. This, setting indicates that ODK > > should be written with compliance to Android SDK version 1.5, however, > > if I set my project build target to version 1.5 I see a few errors > > including > > > In FormEntryActivity on lines 534, 542, and 176 the use of a > > constructor for BitmapDrawable which was not supported until SDK > > Version 5, AKA Android SDK 2.0, found here : > > >http://developer.android.com/reference/android/graphics/drawable/Bitm..., > > java.lang.String) > > > In AudioButton line 43, the use of a method from the Bitmap class not > > available until SDK Version 4, AKA Android SDK 1.6 > >http://developer.android.com/reference/android/graphics/Bitmap.html#g...) > > > I'd just like to get some clarification on the SDK version to use > > Best Regards, > > Gary > > > -- > > Post: opendatakit@googlegroups.com > > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > > Options:http://groups.google.com/group/opendatakit?hl=en

We're grabbing the code from the repo at
https://collect.opendatakit.googlecode.com/hg/ opendatakit-collect

Is this stable or experimental?

How can I grab a slightly more conservative version without any
reference to anything above 1.6?

Hey Neil,
The head of the default branch is unstable. We have a v1.1.5 branch that is
stable and do not contain references above Android 1.6 (which was incidental
and we'll need to remove from default). Checking out from the repo will
give you both branches. To switch, if you're using eclipse and the hg
plugin you can right click on the Collect project, choose Team -> Switch to
-> v1.1.5

From command line you can run: hg update v1.1.5

The v1.1.5 branch is stable and ready for release, but we're waiting on a
bug fix in javarosa before we make it official. The fix has to do with
removing the need for both "short" and "long" tags when using multimedia in
questions and multiple choice answers.

You'll need the latest javarosa build, which you can get here temporarily:
http://cs.washington.edu/homes/chartung/javarosa-libraries.jar

Once the bug is fixed we'll add the new javarosa library to the repo. Let
me know if you have any troubles with 1.1.5.
-Carl

··· On Sun, Oct 24, 2010 at 3:09 PM, Neil Hendrick wrote:

We're grabbing the code from the repo at
https://collect.opendatakit.googlecode.com/hg/ opendatakit-collect

Is this stable or experimental?

How can I grab a slightly more conservative version without any
reference to anything above 1.6?

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.comopendatakit%2Bunsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en