ODK XLSForm Offline Errors: need more than 1 value to unpack

1. What is the problem? Be very detailed.
When using ODK XLSForm Offline, I have received the error message "ODK XLSForm Offline Errors:
need more than 1 value to unpack". I am not sure what this means and how I can change my excel file in order for it not to show an error.

2. What app or server are you using and on what device and operating system? Include version numbers.
I'm using ODK XLSForm Offline and Microsoft excel on Mac, Mojave operating system.

3. What you have you tried to fix the problem?

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
It would be great to have some support as to what this error message is referring to and how I might go about tackling it.

Many thanks!

It would be easier for forum member to give you a solution if you attach form here.

Thank you for responding. I appear to have this error message for all xls forms I try to convert, even ones that have worked successfully when I have used other computers. So perhaps it is not a problem with the form but I am struggling to understand what "need more than 1 value to unpack" means...

Which version of XLSForm Offline are you using? I've seen this error in one context which is when values specified in the parameters column have spaces around the = sign.

For example, consider the documentation for range. If you instead use start = 0 end = 17 step = 1 I believe you can get that strange unpack error.

Hi I'm using v1.11.1. Thanks for this suggestion - I'll give it a try by removing spaces around any =.

@rose1, go into your command line or terminal and run java -version and report what is printed.

My guess is that you have Java 13? If so, the problem is that there is a bug in pyxform, the library that XLSForm Offline uses.

pyxform expects versions are x.y.z format, but the version you have only has x. I fixed the bug a few days ago, but an update has not been released.

Best workaround is to use XLSForm Online at http://opendatakit.org/xlsform or if you really need offline, use Java 11.0.4 from https://adoptopenjdk.net.


Dear Yanokwa,

Thank you for your suggestions. I really appreciate. I couldn't figure out how to type into the command line but I opened Java in my system preferences and it says I am running Version 8 Updated 221. I have used the online one which is working. However, I will need it to work offline soon as I will be moving to Ethiopia where internet is more sparse so any suggestions on getting the offline one working would still be much appreciated.

Many thanks!

@rose1 The Java system preference is not a reliable way to know the various Java versions you have. You'll need to type the java -version the command into the Terminal app. To find the app, go in your Applications folder, then your Utilities folder. Or use Spotlight search to find the app.

We release frequent updates to XLSForm Offline so I expect this issue will be resolved for you soon. When will you be going to Ethiopia?

Thanks a lot. I have found the app but can't seem to type in the terminal. I will be going in a month or two so I have some time. I will try getting the latest update soon.

That's truly genius on your part!