ODK xlsform offline failure to launch on Mac

I have downloaded the xlsform offline application for Mac, when I click to open the app fails to launch. That is the icon flashes but nothing appears in the app dock. "Get info" tells me the app was last opened whenever I clicked the icon.

Using Mac OS X Yosemite 10.10.5
Have tried latest release and v1.5.0 of xlsform offline

I've tried more than once with downloading the app, I've restarted the computer.

I'm assuming this is something obvious to do with the mac as I've previously had no problem with windows. I'm not a computer whizz :slight_smile:

I'm travelling where the internet is unreliable so having this on the Mac would be very helpful.

Many thanks in advance for help.
Regards
Jo

Hi @jo1,

This is not the latest release, can you try another version.

Sorry I was unclear, I tried the latest release v1.9.0 and then I tried an earlier one (v1.5.0) just in case that worked. Both downloaded OK (apparently) but neither will launch.
Thanks for responding so quickly.
Jo

Sorry, am not a mac user.

Have you looked on the note for mac in the documentation?

On macOS 10.7 or later, you may get a dialog on startup warning you that the XLSForm Offline is from an unidentified developer. Control-click or right click the icon of the app to bypass this dialog. See About Gatekeeper for more.

https://docs.opendatakit.org/xlsform/#offline

Thanks I got past that bit :slight_smile: I can see the app icon and the associated text note but it simply won't launch. I think it must be something specific to my Mac set up as I couldn't find anyone else reporting this problem on the forum.

Sorry you are having problems, @jo1. I just tried it on my Mac 10.14 and it works for me :sob:

To be clear, when are control-clicking, seeing this menu, and selecting open?

In your System Preferences, under Security & Privacy, in the General tab, at the bottom of that screen, what do you have "Allow apps downloaded from" set to.

1 Like