ODKmeta do file run problem

1. What is the problem? Be very detailed.
I have a survey designed in kobocollect and was able to export the do file using odkmeta. the do file was exported with out any problem . What I am facing is , once I run the do file the below error is displayed

char start[odk_name] start
variable start not found

2. What app or server are you using and on what device and operating system? Include version numbers.
I am using Stata 16 in windows OS

3. What you have you tried to fix the problem?
have tried to change the csv file but it doesn't seem working

4. What steps can we take to reproduce the problem?

not sure
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

I can share the do file together with the csv file if needed

Hi @tirsit!

Based on your XLSForm, odkmeta expects your CSV file to have a column named start. However, when the do-file runs and actually tries to import the CSV file, it does not find a column named start. Does your CSV file contain a column named start?

I see that another user encountered a similar issue, also involving start. That user was also using KoBoToolbox. Note that odkmeta does expect the submission data CSV files to match the ODK Briefcase export CSV format. The last time I checked, KoBo's CSV format does not match the Briefcase format, and KoBo also isn't working with Briefcase. However, it's been a while since I checked, so you might want to try exporting from KoBo using Briefcase. If you're able to export using Briefcase, you should be able to run the odkmeta do-file on the resulting CSV files. (If you try exporting from KoBo using Briefcase, please report back either way about whether you were able to export successfully!)

Hope this helps!

1 Like

@Matthew_White, thanks for your replay . as suggested I downloaded briefcase to export the data , but I have been trying to pull from kobo sever , for some reasons I couldn't please see the below screenshots and let me know where the problem is ,

I tried changing the URL path - by entering https://..../org, /org/forms... tired many things

Many Thanks


This GitHub issue seems to indicate that KoBo now works with Briefcase. However, I'm not sure what URL you should specify. KoBo has a help page and its own community forum, and you might have luck finding the answer in one of those places.

@Matthew_White, thanks for your recommendation , I was able to be directed how to connect that is , I was coping the Url which I had the forms . however I should have used the url of https://kc/kobotoolbox.org - this way it worked , however when I click pull the form , it says it succeed with errors and the error is as shown below ,

any help pls?
many thanks


Glad you found the correct URL! I'm not sure what the source of that error message is. I'd recommend creating a separate topic in the forum here asking about the error, or asking about it in the KoBo forum.