Old RecForge that writes files to odk dir

Where can i get an old version of RecForge2 that will put the audio files in to the odk/instance/... directory? Yes, i have an old version of odk 1.4.5 (1048) and my scenario requires the old RecForge2 writing the audio files to the odk dir.

Hi @Bob_Achgill1
could you tell us why you need to use that particular audio recorder app and such an old version of ODK Collect?

You can try the search query “recforge ii apk”. Be careful to make sure the site you download from is safe and to identify the right download button (APK download sites often have ads that try to trick users with fake download buttons).

I agree with @Grzesiek2010 that it would be helpful to understand your use case. For example, is it that you have an Android 4.4 device? Or do you need a specific bitrate?

we used that version of odk to make a custom version of odk for volunteers that add their mother tongue into the His Hands Reader literacy language archive. The archived languages are used to make mother tongue literacy video curriculums for any/all languages.

The work flow for a volunteer to add their language has the app enumerate their translated words and voice recordings for each word. They pass me the contents of the odk/instances/.. directory which contain the xml and voice files. Then i run a custom bridge app to absorb the language data into the language archive system.

Each language is then available to be processed to make multilingual literacy curriculums.

Some volunteers still have phones with built-in recording and older version of Android. For these the work flow is good. For volunteers that do not have built-in recording they need access to RecForge2... the old version that writes to the odk directory. Have i got that correct?

Hence, my question... which version of RecForge2 would likely suffice? I found some old versions but when i install them they give a error that the install is corrupt. I dont understand enough about the security changes that Android made. Are the changes that now prevent recording apps like RecForge from writing to the odk dir also causing installs of old versions of RecForge2 to not install.

What can you suggest?

You should be able to use any voice recorder not only that one or maybe I'm missing something?

Have you tried versions form https://recforge-ii.en.uptodown.com/android/versions?

Thanks all! I think the problem with installing the older version of RecForge2 was that i had the latest version installed and that was throwing an error when trying to install the older version. When i removed the the latest version the old version installed fine. Just for the record the 10/28/2017 version 1.2.5g of RecForge2 works to write voice files to tbe odk/instances/.. directory.

1 Like