Problem installing ODK central on digital ocean

During the installation of ODK central on Digital Ocean, after the docker-compose build command I get a fatal error:newspace:rebalance allocation failed - process out of memory - see screenshot.

I am using the 1GB memory, 25GB disk as suggested in the installation tutorial.

I've tried destroying the droplet and this problem has been recreated in different droplets 3 times.

Any help would be greatly appreciated.

Thanks

Replying to myself in case a developer or someone else sees this post.

It was a memory issue during installation. I resized the droplet to 2 GB RAM, ran and finished the install and then resized the droplet back to the 1 GB RAM once everything was up and running. Central appears to be operating fine under the basic $5 plan, it just couldn't install with only 1 GB RAM.

2 Likes

Hi @Ryan_Walsh,

Thanks for the feedback.

Dear All, Good Morning, i have managed to generate SSH Key using PuTTYgen, pasted it in the Control panel, unfortunately i can't login. i am not savvy please give me a step by step. i have followed the Digital Ocean docs so far i am stuck. I need help

Members, I have managed to login to the Console, worked till i arrived at the docer compose build i see red and blue lines. I am i on track?