Hi, everyone.
in order to point it to my droplet (for Aggregate v2), i've set up a FreeDNS subdomain ( ;
I've indicated my DO droplet ip address (mydroplet-ip-address) as its destination,
set A record within my droplet Network wizard, does not point to my droplet;
I've just sent an e-mail to FreeDNS support team, but I still waiting for their reply.
in advance, thanks for your help.

All you need to do is to add the Droplet's IP address as the destination in FreeDNS. You do not need to do anything in DO.

Thanks, @yanokwa.
After doing this, how do I know that it works: because, when I check the domain (by typing it in the url bar) in a web browser, I still not seeing the Aggregate web site.
thanks, again

You can check on to see if your domain name points to your Droplet's IP address. Once that site shows the link, it should work. It typically takes a few hours.

Yes, that site shows my droplet's IP address.
So, after a few hours, I will type my domain in the address bar of a browser to see my Aggregate web site, before proceeding my installation?!
many thanks, @yanokwa

Hi, @yanokwa.
My Aggregate web site still not loading;
and my droplet seems to have a configuration issue (maybe there is a problem in the cloud-config script here
because, the following checkings showed:

  1. in my droplet console, I ran the command: ss -plnt
    (to check which services are running and which listening ports )
  2. in the same console, I ran the command:
    service nginx restart (to see if nginx is running)
    thank for your help

Hmm. Not sure what is happening here...

If you are able, spin up a new server (The "Create your droplet" steps at

Once that's done, stop and run this command to upload the output to the public website.

cat /var/log/cloud-init-output.log | nc 9999

The above command will give you a link (e.g., that you can share with me.

Sorry, sorry, @yanokwa; I just realized a big mistake I was making; Everything is fine now.
Thanks to you so much.

@Amal Can you share your mistake? We might be able to adjust the docs accordingly.

in the cloud-config script here,
I've erased the first line "#cloud-config", thinking it is a commented line.
When, following your advice, I spun up a new server (but, without erasing that line), all things work fine.
Again, sorry.

1 Like

A post was split to a new topic: Aggregate not installing on Ubuntu focal