Problem Setting Up Central Server on Digital Ocean -- certbot failed Could not find keyfile file

1. What is the issue? Please be detailed.
I am a longtime SurveyCTO user but completely new to ODK. I am trying to set up my Central Server (since my project will be completely off the cloud...I just need an environment to test form building and don't have a budget for a hosted account when I only need a development sandbox to test form building and fake submissions).

I followed the following:

I signed up for DigitalOcean. I created a DNS using GoDaddy. The server says it is healthy when I start it but when I go to my website I get the error "Unable to connect". It has been more than 24 hours since I did all the configuration.

I am very novice at server configuration. I try to be detail oriented and am willing to learn!

2. What steps can we take to reproduce this issue?
I have included screenshots with my build information, error log, and my DNS configuration information. I did try to use a different DNS (the free one) first and was confused so switched to GoDaddy and then, using the command nano .env, updated my config file with the GoDaddy website after the fact and then rebuilt. Maybe that introduced some issue?

3. What have you tried to fix the issue?
I have tried stopping, rebuilding, and restarting. I have looked through your support tickets and ran docker-compose logs nginx to see any errors. I do see an error "certbot failed Could not find keyfile file" and have included a screenshot with the full error.

Please kind people, help me when you get the chance! :slight_smile: Thank you! Thank you!

4. Upload any test forms, screenshots, or logs below. is working for me. I think maybe your DNS was a little slow to update


Thank you so much for the quick reply Yanokwa!

It is working for me now too. I am so happy! I read that it can take up to 48 hours for the DNS to work but I was under the impression that it is usually in just a few hours. Being new to all of this, I assumed that I must have done something wrong.

So glad it turns out it was fine and sorry to bother you. :slight_smile: