Problem uploading a form

Hello everyone!

This is my very first post and I must confess I'm not an expert at all in programming, coding, etc. so I struggle a lot with odk. I'm very sorry if this was discussed in previous post but I couldn't solve the problem reading old posts.

What is the problem? Please be detailed.

I can't upload a form that shows constantly this message: "Problem with JavaRosa Parsing Form: org.opendatakit.aggregate.exception.ODKIncompleteSubmissionData: Javarosa failed to construct a FormDef. Is this an XForm definition?"

I previously used a very similar form that I actually used as an example that perfectly worked, so I don't get why my I can't now.

What ODK tool and version are you using? And on what device and operating system version?

ODK aggregate. Computer. Microsoft 10.

What steps can we take to reproduce the problem?

I would upload the form, but I have no permission as a new user.

What you have you tried to fix the problem?

I checked several times how I constructed the fields and saved in xml in different ways.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Welcome, @tucumano!

Sorry to hear you're having these troubles. Would it be possible for you to upload the form somewhere else like Google Docs or Dropbox and share the link here? It's going to be hard for someone to help without seeing the form.

Hi @LN!
Thanks for your fast reply. I'll do so when I get home and see if some of you guys can't help me out. I'm pretty sure is very easy to solve for those who understand well the structure of the forms :stuck_out_tongue:

Let's hope so! You should also try really quick to attach it directly in your response again. Now that you have a couple of posts I think you will be able to.

Hello there, as you said it, if you don’t have any background in programming it wouldn’t be easy to fixe it by yourself. Normally the message error appears in the terminal of Apach.
Could you upload your form here pleas?

Hi guys! Thanks for your help. I finally solved it by coping my own form in a sample form. I think there was a problem of construction of the table. Anyway, thank you again and is very nice to see there's a group of people willing to help so fast :slight_smile:


Hello Tucumano, your welcome.