Problem with enabling https for aggregate on google cloud

1. What is the problem? Be very detailed.
We are attempting to set up odk aggregate using the google cloud server. We have followed the instructions given here:

We are at the enable https step where we add the following code after clicking the ssh button:
sudo certbot run --nginx --non-interactive --agree-tos -m YOUR_EMAIL --redirect -d YOUR_DOMAIN

(obviously we changed it to our email and domain name, I can provide if necessary)

When we run the code we get an error message, and we are unable to access aggregate with (we can without the https though).

The output and error message is attached in the below screenshot.

We do not know where to go from here.

2. What app or server are you using and on what device and operating system? Include version numbers.

We had the same results using both windows and mac computers, using google cloud for aggregate.

3. What you have you tried to fix the problem?

We have tried changing the email address, adding www in front of our domain name, trying to re-install Nginx.
Note: we are not programmers, so we don't really know what we are doing.

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

A post was merged into an existing topic: Unable to resolve host

@Rachel_M Did you follow step 12 at and set your entire domain ( in Google Cloud's networking tab?