Problem with Excel 2010 to open properly csv file coming from ODK aggregate

Hi All,

I have data coming from a .csv file generated on ODK aggregate. When I open
my .csv file with Excel 2010 I have issue with comma (,) in the field.
Indeed with Excel 2010 my values are split in two different cells even
though if I have double-quotes marks around them (i.e. "Marie, Jane").
However with Excel 2013 this issue doesn't occur.
The XLS form for my questionnaire have been created using Excel 2013

  1. Someone knows if this can explain why my data is correctly imported
    using Excel 2013 and not on Excel 2010?
  2. As someone ever had this problem ?

Thank you in advance
Sun

A quick workaround, change your computer settings for list separator.

Change it from "," to |

and then try opening the file again.

Here's how you can change the separator:

··· -------------------------------------------------------------------------------- mCollect : Customized data collection app built on ODK

Thanks & Regards,

Swapnil Agarwal

Co-Founder | Director

Dhwani Rural Information Systems Pvt. Ltd.

Phone +91-9099067758/+91-8899635577 | Work email: swapnil@dhwaniris.com

Web: http://www.dhwaniris.com/ http://www.dhwaniris.com/

P

Please don't print this e-mail unless you really need to

On Thu, Sep 10, 2015 at 2:00 PM, Sun nashsunap@gmail.com wrote:

Hi All,

I have data coming from a .csv file generated on ODK aggregate. When I
open my .csv file with Excel 2010 I have issue with comma (,) in the field.
Indeed with Excel 2010 my values are split in two different cells even
though if I have double-quotes marks around them (i.e. "Marie, Jane").
However with Excel 2013 this issue doesn't occur.
The XLS form for my questionnaire have been created using Excel 2013

  1. Someone knows if this can explain why my data is correctly imported
    using Excel 2013 and not on Excel 2010?
  2. As someone ever had this problem ?

Thank you in advance
Sun

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

See https://opendatakit.org/help/form-design/workarounds/#csv_output

··· On Thu, Sep 10, 2015 at 2:01 AM, Swapnil Agarwal wrote:

A quick workaround, change your computer settings for list separator.

Change it from "," to |

and then try opening the file again.

Here's how you can change the separator:
http://www.howtogeek.com/howto/21456/export-or-save-excel-files-with-pipe-or-other-delimiters-instead-of-commas/


mCollect http://www.dhwaniris.com/mcollect: Customized data collection
app built on ODK

Thanks & Regards,

Swapnil Agarwal

Co-Founder | Director

Dhwani Rural Information Systems Pvt. Ltd.

Phone +91-9099067758/+91-8899635577 | Work email: swapnil@dhwaniris.com

Web: http://www.dhwaniris.com/ http://www.dhwaniris.com/

P

Please don't print this e-mail unless you really need to

On Thu, Sep 10, 2015 at 2:00 PM, Sun nashsunap@gmail.com wrote:

Hi All,

I have data coming from a .csv file generated on ODK aggregate. When I
open my .csv file with Excel 2010 I have issue with comma (,) in the field.
Indeed with Excel 2010 my values are split in two different cells even
though if I have double-quotes marks around them (i.e. "Marie, Jane").
However with Excel 2013 this issue doesn't occur.
The XLS form for my questionnaire have been created using Excel 2013

  1. Someone knows if this can explain why my data is correctly imported
    using Excel 2013 and not on Excel 2010?
  2. As someone ever had this problem ?

Thank you in advance
Sun

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Microsoft Office has many issues with CSV. It can't even tolerate CSV's
having non-ANSI unicode data (like Hindi - हिंदी)

I recommend you use LibreOffice Calc to work with CSV files.
Here, every time you open it, it asks you properly about the encoding, the
field separators, previews your data, etc in a popup window before loading.
So there is no long-winded process of changing settings every time you use
a different CSV.
It's even great for saving tables as CSV : again giving you all the options
of picking a field separator, quotes, etc.

https://www.libreoffice.org/download

··· On Thursday, September 10, 2015 at 11:59:04 PM UTC+5:30, Mitch Sundt wrote: > > See https://opendatakit.org/help/form-design/workarounds/#csv_output > > On Thu, Sep 10, 2015 at 2:01 AM, Swapnil Agarwal <swapni...@gmail.com > wrote: > >> A quick workaround, change your computer settings for list separator. >> >> Change it from "," to | >> >> and then try opening the file again. >> >> Here's how you can change the separator: >> http://www.howtogeek.com/howto/21456/export-or-save-excel-files-with-pipe-or-other-delimiters-instead-of-commas/ >> >> >> -------------------------------------------------------------------------------- >> mCollect : Customized data collection >> app built on ODK >> >> Thanks & Regards, >> >> Swapnil Agarwal >> >> >> Co-Founder | Director >> >> >> >> Dhwani Rural Information Systems Pvt. Ltd. >> >> Phone +91-9099067758/+91-8899635577 | Work email: swa...@dhwaniris.com >> >> >> *Web: http://www.dhwaniris.com/ * >> >> >> P >> >> Please don't print this e-mail unless you really need to >> >> On Thu, Sep 10, 2015 at 2:00 PM, Sun <nash...@gmail.com > wrote: >> >>> Hi All, >>> >>> I have data coming from a .csv file generated on ODK aggregate. When I >>> open my .csv file with Excel 2010 I have issue with comma (,) in the field. >>> Indeed with Excel 2010 my values are split in two different cells even >>> though if I have double-quotes marks around them (i.e. "Marie, Jane"). >>> However with Excel 2013 this issue doesn't occur. >>> The XLS form for my questionnaire have been created using Excel 2013 >>> >>> 1) Someone knows if this can explain why my data is correctly imported >>> using Excel 2013 and not on *Excel 2010?* >>> 2) As someone ever had this problem ? >>> >>> Thank you in advance >>> Sun >>> >>> -- >>> -- >>> Post: opend...@googlegroups.com >>> Unsubscribe: opendatakit...@googlegroups.com >>> Options: http://groups.google.com/group/opendatakit?hl=en >>> >>> --- >>> You received this message because you are subscribed to the Google >>> Groups "ODK Community" group. >>> To unsubscribe from this group and stop receiving emails from it, send >>> an email to opendatakit...@googlegroups.com . >>> For more options, visit https://groups.google.com/d/optout. >>> >> >> -- >> -- >> Post: opend...@googlegroups.com >> Unsubscribe: opendatakit...@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> >> --- >> You received this message because you are subscribed to the Google Groups >> "ODK Community" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to opendatakit...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com >