Problem with installing Aggregate v1.4.14

I am trying to install the newest version of aggregate using the google app engine and when i run and finish the installer and try to launch the upload tool i get the following vague error:

"There has been an error.
Unknown error while running java -jar.\ODKAggregateAppEngineUpdater.jar
The application will exit now."

I am following the instructions found here:
to set up a new google app engine project, and install aggregate for the first time to deploy a project. I am currently stuck on step 12 or 13.

What ODK tool and version are you using? And on what device and operating system version?
I am using ODK Aggregate v1.4.14 for a PC on a desktop PC running Windows 7 Home Basic 64 bit.

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?
I thought that the problem might be with my google application ID that I entered in the installer. I tried using both my google project ID and project number when running the aggregate installer, but neither fixed the issue and both produced the same vague error message.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Thank you for any help you can offer.

The issue with the installer was solved, however, I still cannot access Aggregate from my google app engine. I am now stuck at step 20 of the following instructions

and I am getting the following error message:

"This site can’t be reached
uem-cfar-hiv-survey’s server DNS address could not be found.
Try running Windows Network Diagnostics.

Any idea on what I have done wrong and how to access Aggregate? Thank you for your help.

For others with a similar issue with the installer: I fixed the issue by making sure to create a folder to save the ODK aggregate files into under My Documents and also ran the installer from the Downloads section of my computer not from the web browser.

I have tried using different browsers to access ODK aggregate from my google app engine (chrome, firefox, internet explorer), they all give the same error message.

I tried the trouble shooting suggestion and changed the DNS address by using this instructions:

but it did not work.

Is there a way to get a form into ODK collect without using Aggregate, perhaps adding it manually into ODK collect?

Any help would be greatly appreciated as I am struggling to get Aggregate up and running to begin project deployment.


Is there a way to get a form into ODK collect without using Aggregate, perhaps adding it manually into ODK collect?

You can just copy your form into odk/forms directory on your device.
The second option is to use Google Drive - you can copy a form to your space on GD and then download it (you need to change your server in Settings - go to General Settings -> Server -> Type and select Google Drive, Google Sheets option. In the same page you have to select your google account (it's the second option). After that if you click Get Blank Form button from the main menu you should be able to see your space and your forms.


Thank you Grzegorz! This worked :slight_smile: do you have any ideas about what I am doing wrong with setting up Aggregate and getting the DNS error? I really appreciate your help. You saved me for my meeting today.

unfortunately I have no idea what's wrong with your configuration. To be honest I'm not really experienced when it comes to Aggregate (I work on Collect app) but I configured my own server last month without any problems so if you want I can try to do that for you.
So if you want please create a new google account and send me your username and password then I'll try to setup Aggregate for you and then you can change the password. Does it work for you? If so let's continue the discussion using private messages or skype (grzegorz.soldevelo).


Thank you for the help!! I can now access Aggregate.

Great! let us know in case of any other problems.


A post was split to a new topic: Unknown error while running Aggregate jar

A post was split to a new topic: Aggregate not installing