Problems with Enketo on self-hosted Kobo server

I'm having the same issues with the setup on our server.
Will you be able to provide details on how this issue was resolved? From our setup, all the services are up and the logs did not reveal anything suspicious other than the normal.


What version of Central are you running? What, if anything, changed before this happened? What you tried so far to fix it?

Have tried responding to you several times but it does not seem to go through

I'm running kobotoolbox version 2.022.08

Before this issue started, there was an abrupt power loss on the server that causes DB files to be corrupted. Have to restore each database to resolve the corruption. Yet there have been similar situations before and we never had the above error.

I have tried:

  • Inspecting the logs and the containers over and over again and nothing seem to be usual.
  • Remove kobocat, enketo, and kpi images and re-run the setup.
  • Inspect docker network and everything is as usual.
  • Troubleshoot to ensure that containers can reach one another via pinging with their internal domain (something like domainName.internal).
  • Tried creating a project, deploying a form, and still having the above issue while trying to submit a case.
  • Open the form for online-only submission and in incognito tab, the above issue still occurs while trying to submit the case.

Sorry you are having trouble with Kobo. Questions about KoBo should go to

1 Like