Problems with missing Data from Aggregate Using Latest Release of Briefcase

I lost some data on my csv file after pulling submitted forms from Aggreegate.
Some of the columns are filled with strokes (-) instead of values (time and codes)

I used Samsung Galaxy tablet with ODK v1.15.2 and HUAWEI MediaPad with ODK v1.12.2 to get forms from Aggregate, collect data and submit encrypted forms to server
Using Windows 10 desktop with the latest release of ODK Briefcase to pull the decrypted data, I realised somme columns are without data

Can someone please help out


  1. What specific version of Briefcase and Aggregate are you using. "Latest" doesn't help because we ship updates frequently?
  2. Is there any pattern to the columns that have missing data? Is it always dateTime columns? Is it a particular device? A particular enumerator?
  3. Since the form is encrypted, it'll be hard to figure out where the problem happens. Have you tried the same form unencrypted on the same device and seen if Collect has that data in the raw XML and Aggregate shows that data in the dashboard?
  4. Have you tried a much older version of Briefcase (e.g., to see if that helps?

Dear Yaw

I used Aggregate v1.0 and ODK-Briefcase-v1.11.2.jar
There also seem to be a mix up of older version which I deleted but apparently remained in the junk. Briefcase exports 49 observations instead of 48 (including a junk form which I suppose is the test form which was deleted as an updated version was uploaded.

Both devices show the same pattern. One particular column is completely missing (participant id which is in the updated form but not on the old form which was removed after a test pull and export)

I have tried using ODK Briefcase v1.4.9.Pro but indicates the same set of missing data

I also want to know how to avoid exporting a test form which was exported but nolonger valid. May be a way to limit exportations to 48 observations as on the server


You are using Aggregate v1.0 from November 2011? Are you absolutely sure. That would mean you installed it seven years ago.

No sorry, the Aggregate was installed in June this year
I noticed the pulling made use of Aggregate v1.0

I will be grateful

Looking at the pulled and exported dataset, I realized the dataset makes use of the variables names of the originally decrypted test form which does not match with the updated versions of the forms submitted after deleting the test form on the server.
It shouldn't be therefore surprising that the variable names should not carry any values.

I guess the problem could be at the level of fishing out the deleted test forms from the junk and deleting it or prohibiting it from being part of the pulled data
Is there an option in the server or Briefcase settings to handly this?

Unfortunately, briefcase doesn't call-up all submissions for one to choose which submissions to pull and export.


Dear Yaw,

I have resolved the problem, I just needed to clean the Briefcase memory.
It was a good experience worth living
We can't fast track learning until there be challenges


1 Like

I love your attitude! And speaking of learning, what do you mean by cleaning Briefcase's memory? What exactly did you do?

Your reply on Features just said exactly what the issue was.
Little did I know Briefcase has stored an old test form I pulled and exported.
I had to go to my Briefcase location and delete the old test form (XML)


1 Like