Project Administrator app usage allow?

1. What is the issue? Please be detailed.

When running ODK Collect on Android x86 9 in VMWare, there's no simple way to get camera access

You get an error that reads
Barcode Scanner
Sorry, the Android camera encountered a problem. You may need to restart the device. (OK?)

Then the app quits.

If you deny camera access, the app asks for camera access. If you don't give it, the app quits.

2. What steps can we take to reproduce this issue?

  • fire up Android x86 9 on VMware Workstation
  • install ODK collect from the play store
  • add project, try to find a way to make that work with collect
  • wonder why user/pass of an admin account doesn't have app access, given you can enter the credentials. Strange.
  • manually import the QR code, for some reason the app insists on camera permissions
  • refuse, can't import the project
  • grant, app quits (same error as above)
  • Go back to trying to debug this issue, try entering the long URL, not likely without some typo.
  • be sad and frustrated.
  • go to dinner and drink a little extra to feel better
  • try again tomorrow.

3. What have you tried to fix the issue?

  • reboot
  • quit restart
  • click many times
  • tab around

4. Upload any forms or screenshots you can share publicly below.

Screenshot from 2023-03-17 21-00-23
Screenshot from 2023-03-17 21-00-41