Publish failure because of bad credential - in ODK Aggregate on Tomcat

I have installed ODK aggregate on a server with Tomcat and Postgres. Everything works fine, only publishing to GME gives error.

I have setup OAuth for a google account and uploaded the same in ODK aggregate. Now I can publish to Fusion tables. Same google account is an admin for GME and created Vector table in GME using following KML file.

<?xml version="1.0" encoding="UTF-8"?> GME Geo Tagger 0,0,0

When I try to publish the data using assert id of above created GME vector table, getting status as "Restart Publisher - Credential was BAD". I dont know what I am doing wrong here. Please help.

Thanks,
Prabu Raja

I've updated the instructions here:
http://opendatakit.org/use/aggregate/oauth2-service-account/

There is a "Google Maps Engine" API that you need to set "ON" in order for
the GME publishing to work.

··· On Wed, May 14, 2014 at 2:36 AM, wrote:

I have installed ODK aggregate on a server with Tomcat and Postgres.
Everything works fine, only publishing to GME gives error.

I have setup OAuth for a google account and uploaded the same in ODK
aggregate. Now I can publish to Fusion tables. Same google account is an
admin for GME and created Vector table in GME using following KML file.

<?xml version="1.0" encoding="UTF-8"?>



GME Geo Tagger











0,0,0




When I try to publish the data using assert id of above created GME vector
table, getting status as "Restart Publisher - Credential was BAD". I dont
know what I am doing wrong here. Please help.

Thanks,
Prabu Raja

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

I've updated the instructions here: http://opendatakit.org/use/aggregate/oauth2-service-account/

There is a "Google Maps Engine" API that you need to set "ON" in order for the GME publishing to work.

I have installed ODK aggregate on a server with Tomcat and Postgres. Everything works fine, only publishing to GME gives error.

I have setup OAuth for a google account and uploaded the same in ODK aggregate. Now I can publish to Fusion tables. Same google account is an admin for GME and created Vector table in GME using following KML file.

<?xml version="1.0" encoding="UTF-8"?>
<name>GME Geo Tagger</name>

<Folder>

  <!-- Placemark is needed to build the data store -->

  <Placemark>

    <ExtendedData>

      <Data name="/data/meta/instanceId"/>

      <Data name="/data/meta/instanceName"/>

      <Data name="/data/geolocation"/>

      <Data name="/data/name"/>

    </ExtendedData>

    <!-- Replace with a polygon to set the zoom level -->

    <Point>

      <coordinates>0,0,0</coordinates>

    </Point>

  </Placemark>

</Folder>

When I try to publish the data using assert id of above created GME vector table, getting status as "Restart Publisher - Credential was BAD". I dont know what I am doing wrong here. Please help.

Thanks,

Prabu Raja

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

Thanks Mitch for your response.

I already enabled "Google Maps Engine API" but not working. I wasn't configured "Consent screen" which I did now, but no luck. When I go to "API console" page I can see request made counts increasing and error counts also increasing. But I don't know what going wrong here.

··· On Wednesday, May 14, 2014 11:28:03 PM UTC+5:30, Mitch Sundt wrote: > On Wed, May 14, 2014 at 2:36 AM, wrote:

I would engage the GME folks and Nafundi. This was code they contributed
and they may have changed the interfaces since it was last released???

··· On Wed, May 14, 2014 at 12:01 PM, wrote:

On Wednesday, May 14, 2014 11:28:03 PM UTC+5:30, Mitch Sundt wrote:

I've updated the instructions here:
http://opendatakit.org/use/aggregate/oauth2-service-account/

There is a "Google Maps Engine" API that you need to set "ON" in order
for the GME publishing to work.

On Wed, May 14, 2014 at 2:36 AM, prab...@gmail.com wrote:

I have installed ODK aggregate on a server with Tomcat and Postgres.
Everything works fine, only publishing to GME gives error.

I have setup OAuth for a google account and uploaded the same in ODK
aggregate. Now I can publish to Fusion tables. Same google account is an
admin for GME and created Vector table in GME using following KML file.

<?xml version="1.0" encoding="UTF-8"?>
<name>GME Geo Tagger</name>

<Folder>

  <!-- Placemark is needed to build the data store -->

  <Placemark>

    <ExtendedData>

      <Data name="/data/meta/instanceId"/>

      <Data name="/data/meta/instanceName"/>

      <Data name="/data/geolocation"/>

      <Data name="/data/name"/>

    </ExtendedData>

    <!-- Replace with a polygon to set the zoom level -->

    <Point>

      <coordinates>0,0,0</coordinates>

    </Point>

  </Placemark>

</Folder>

When I try to publish the data using assert id of above created GME
vector table, getting status as "Restart Publisher - Credential was BAD". I
dont know what I am doing wrong here. Please help.

Thanks,

Prabu Raja

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

Thanks Mitch for your response.

I already enabled "Google Maps Engine API" but not working. I wasn't
configured "Consent screen" which I did now, but no luck. When I go to "API
console" page I can see request made counts increasing and error counts
also increasing. But I don't know what going wrong here.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

And if you have logs, that'd be great to have them. Feel free to email
them to me directly.

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Thu, May 15, 2014 at 11:22 AM, Mitch Sundt mitchellsundt@gmail.com wrote:

I would engage the GME folks and Nafundi. This was code they contributed and
they may have changed the interfaces since it was last released???

On Wed, May 14, 2014 at 12:01 PM, prab.raja@gmail.com wrote:

On Wednesday, May 14, 2014 11:28:03 PM UTC+5:30, Mitch Sundt wrote:

I've updated the instructions here:
http://opendatakit.org/use/aggregate/oauth2-service-account/

There is a "Google Maps Engine" API that you need to set "ON" in order
for the GME publishing to work.

On Wed, May 14, 2014 at 2:36 AM, prab...@gmail.com wrote:

I have installed ODK aggregate on a server with Tomcat and Postgres.
Everything works fine, only publishing to GME gives error.

I have setup OAuth for a google account and uploaded the same in ODK
aggregate. Now I can publish to Fusion tables. Same google account is an
admin for GME and created Vector table in GME using following KML file.

<?xml version="1.0" encoding="UTF-8"?>
<name>GME Geo Tagger</name>

<Folder>

  <!-- Placemark is needed to build the data store -->

  <Placemark>

    <ExtendedData>

      <Data name="/data/meta/instanceId"/>

      <Data name="/data/meta/instanceName"/>

      <Data name="/data/geolocation"/>

      <Data name="/data/name"/>

    </ExtendedData>

    <!-- Replace with a polygon to set the zoom level -->

    <Point>

      <coordinates>0,0,0</coordinates>

    </Point>

  </Placemark>

</Folder>

When I try to publish the data using assert id of above created GME
vector table, getting status as "Restart Publisher - Credential was BAD". I
dont know what I am doing wrong here. Please help.

Thanks,

Prabu Raja

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

Thanks Mitch for your response.

I already enabled "Google Maps Engine API" but not working. I wasn't
configured "Consent screen" which I did now, but no luck. When I go to "API
console" page I can see request made counts increasing and error counts also
increasing. But I don't know what going wrong here.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com