Pulldata error: question answers get deleted when not using csv file data

1. What is the problem? Be very detailed.

We have an xls form that uses the pulldata function to populate a handful of questions inside our form using an "ID" field as the key ("parent_study_id_key").

Inside the ODK Collect custom app we've built (also tested with ODK Collect from Google Play store itself) it works fine whenever we enter an ID that exists inside the csv file used for pre-loading data.

However, when we enter an ID that does not exist in the csv (because it's a new person we are interviewing therefore we don't need to preload any data), and answer all questions manually, at the end of the form it does not allow us to save. It instead sends us back to the specific questions where we have put the pulldata function and shows them as empty (so it erases our manually entered new data) and requires them to be filled (because these questions are required). This loop continues and we cannot save the form with new data.

We can send the csv file and the xls form by email if requested.

2. What app or server are you using and on what device and operating system? Include version numbers.

ODK Collect based app & ODK Aggregate server

3. What you have you tried to fix the problem?

Made questions not required: the form can be finalised but the answers in question still get deleted.

Any pointers much appreciated!!

Screenshot from xls form:

Screenshot from csv file:

Calculations are recalculated while Savigny the form. If no data were found in the csv any field you entered in the form will be replaced by an empty value by the end...

This is annoying i tried using once( before the pulldata but nothing happens !

Another Wayne to bande that is to pulldata in a seperate variable and then recall this variable on the field tou need.

You'll end with 2 rows in your data set with first empty or prefilled data and a 2nd with the pulldata or filled data.

1 Like