Pulling forms from ODK Aggreagte using Briefcase

Dear all,

I am using ODK Briefcase v.1.13.1. Yesterday, I downloaded a form and data from the Aggreagte server and it worked out without any problems. Since I exceeded the daily quota I needed to add the billing information for the ODK Aggregate server. Today, I have tried again to pull the remaining forms from the server. However, I didn't succeed. The error message I get already after chunk 1 is: "
Submission not retrieved: org.opendatakit.briefcase.util.ServerFetcher$SubmissionDownloadException: Fetch of a submission failed. [....] Please verify that the URL, your user credentials and your permissions are all correct."

However, the username and password should be correct since I can log in on the ODK Aggregate side. I am using the admin account which is why I also don't think that missing permissions cause this problem. And also the URL should be the correct one.

Any help is very much appreciated.

Thank you.

Welcome to the ODK forum, @KR! We're glad you're here. When you get a chance, please introduce yourself here. I'd also encourage you to add a real picture as your avatar because it helps build community!

If you get the forms lists on Briefcase after setting the Aggregate URL and credentials, you should be OK on that front.

The log file briefcase.log could give us more information about this problem. Could you attach here, please?

Also, maybe there's some issue server-side. You could see if there's any warning or error level messages in the logs at https://console.cloud.google.com/logs/viewer

Dear Guillermo,

thanks very much for your suggestions. In attachment both the logfile from briefcase as well as a csv file containing the information about the logs. Please note that in the morning I used several times a wrong password which might be noted in the logfiles. But also after realizing this mistake it didnt work.

briefcase.zip (191.2 KB)
logging_report.csv (3.0 KB)

Thanks for your help!

1 Like

OK, it's definitely something to do with the server (it's responding with HTTP 500 error codes). Unfortunately, I can't say much about the log file you've attached.

Could give me (ggalmazor@gmail.com) permission to check the logs of your Google Cloud Project? Otherwise, I would need the logs in some format different than the one you attached before.

I managed to solve the problem. The problem was that I have several forms with the same title on the Aggregate server (but different form ids). So after renaming the folders in the Briefcase storage location, I managed to download the remaining forms from the server.

Thanks again for your help!