Relevant Problem and Questions not showing up

1. What is the problem? Be very detailed.
(1) A group of questions that I have added to an XLS form will not show up unless I add a relevant statement from an earlier question. If I leave the relevant column blank, it just doesn't show that group of questions at all.
(2)I have a problem with logic working in an XLS form. Within a group of questions the respondant must answer a question that is a 'select_multiple'. Based on how they respond to this question I want a secondary group of questions to show up. When I add in the relevant statement for the secondary group of questions to say ${name}='1' nothing will show up.

2. What app or server are you using and on what device and operating system? Include version numbers.
I am using an XLS form on Windows 10. I have been using KOBOToolbox to upload forms
3. What you have you tried to fix the problem?
checking for errors in variable names and labels. Looking at online resources

4. What steps can we take to reproduce the problem?
Assist to advise how to properly code the XLS form to have groups of questions show up when needed (with or without relevant statements)
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

In screen shot the 'gmed' group will not show up on the survey unless I put a relevant statement from an earlier answered question.

The 'gism' group will not show up at all, even with the relevant statement

Are you able to upload the XLSForm file for the rows shown in the screenshot? It will make it easier for someone to troubleshoot.

1 Like

I have uploaded the file here. I appeciate any help I can get about (1) having the group question show up and (2) doing relevant statements based on select_multiple outcomes.


Treatment 19-02-2020.xlsx (26.0 KB)

The syntax for a relevant that references a select_multiple is slightly different.
You need to change it from: ${med}='1' to selected(${med},'1')

See this section of the XLSForm docs:

Thanks, I was able to get the form to work when I use the selected(${med},'1'), but only when I updated all of my relevant statements to be consistent with the above form. It also made the question that wasn't showing up at all show up. I guess all the revelant statements have to be consistent or it won't work?

Either way works now :slight_smile: