Responses in single/multiple choice questions not visible when I swipe back

1. What is the problem? Be very detailed.
The problem started yesterday, and is visible across all the surveys (both new and old) on my tablet. When I choose an option in single/multiple choice questions, and then swipe forward to the next page, normally the data is saved and visible if I choose to swipe back. However, now when I swipe back to a previous page in the survey, all single/multiple choice options are once again blank - they do not appear to have recorded the choices which have previously been made. By contrast, data entered into open text questions is still visible when swiping back to earlier pages in the survey.

2. What app or server are you using and on what device and operating system? Include version numbers.
I am using a Lenova Yoga Tablet. It is about 2 years old. It has worked well up till now.

3. What you have you tried to fix the problem?
I have re-installed ODK Collect onto the tablet (most recent version). I have deleted all saved forms, and re-downloaded blank survey templates from the ONA website. The same problem persists across all the re-downloaded surveys on the tablet.

4. What steps can we take to reproduce the problem?
I dont know. Sorry.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

The first image shows the data as entered.
The second image shows the same screen after I have swiped forwards and then back again. The open text responses are visible, but the single/multiple entry responses are not i.e. Oda Bokota is no longer seen as having been chosen.

Can you please link to one of the blank survey templates from the ONA website that you can reproduce this issue with?

Hello LN,
Thank you for your response. My apologies for the delay in responding to you. I am travelling for work in Northern Ghana and Burkina Faso, and I have limited access to internet. In addition, I am not familiar with the ODK Forum interface, so please bear with me.
In response to your question, I am experiencing this problem at the moment with any/all ODK surveys on my tablet.

I attach (I hope) one of the surveys currently on ONA and on my tablet for which I experience the problem. But I could have attached any of the other surveys as well, as they all present the same problem. Thank you.

D_TREE_DATA_BC1_Dec19_FINAL.xls (547.5 KB)

Your survey seems to work well for me. Can you confirm that you have ODK Collect v1.25.1 from the Play Store? What version of Android are you running? Can you confirm that if you connect to the default server (go to General Settings > Server > Url, tap on it and use the dropdown to select you see this behavior as well on the All Widgets form's select questions? Have you been able to reproduce this on any other device?

Hello LN,
Thank you for your email.
I am running ODK v1.25.2, and Android 6.0.1
The behavior is repeated on the All Widgets form (downloaded from the default server).
I have not been able to reproduce this on another device.
Thank you LN for your on-going interest and support.
Very best wishes,
David Baines

Unfortunately there's not much we can do without a reproduction. It sounds like there's something bad about the state of your device. One thing you could do is reset Collect by going to Admin Settings, tapping Reset application... and selecting every option to reset. I can't really imagine what the problem could be but there's a chance that this could help.

Since this looks pretty serious, we've done some follow-up and it looks like our quality assurance team has reproduced an Android 6 issue that looks just like this: If this is indeed the same issue, there is no data loss -- the selected value is saved but not displayed. Naturally, it's very confusing so it's something we want fixed as soon as possible. Thanks for reporting and providing version details.

@Grzesiek2010 is working on a fix and we'll tag you in a beta to try once it's ready.

1 Like