Script error when running ODKAggregate on Chrome, Firefox and Mobile devices

Hello

The Aggregate server is almost unusable now. Every-time I try to use it I get a script error as below:

"Warning: Unresponsive script. A script on this page may be busy or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. Script: https://A.B.C.D:port/ODKAggregate/Aggregate.html:117"

After pressing stop script, one can use aggregate for about a minute before it freezes and then the warning pops up again.

I have v1.4.5 installed.

Looking forward to a quick response.

Thanks

This issue might be caused by browser plug-ins or pop-up suppression
scripts. A quick test is to open an Incognito or Private Browsing window
and access ODK Aggregate through that. Does it work better? If so, then it
is a browser plug-in incompatibility.

Next, update to a newer ODK Aggregate.

See

for how to upgrade.

And finally, you may also be encountering issues with the Google Maps API.
This might be mitigated by configuring an API Key for your server.
https://opendatakit.org/use/aggregate/oauth2-service-account/
This should be done only after you have upgraded.

ยทยทยท On Mon, Feb 20, 2017 at 2:54 AM, wrote:

Hello

The Aggregate server is almost unusable now. Every-time I try to use it I
get a script error as below:

"Warning: Unresponsive script. A script on this page may be busy or it may
have stopped responding. You can stop the script now, or you can continue
to see if the script will complete. Script: https://A.B.C.D:port/
ODKAggregate/Aggregate.html:117"

After pressing stop script, one can use aggregate for about a minute
before it freezes and then the warning pops up again.

I have v1.4.5 installed.

Looking forward to a quick response.

Thanks

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

I have experienced this issue for years and all upgrades and browser changes have not worked.
One thing I realized is that the issue only starts when there are a number of forms on the server. Seems there is a script that keeps running in the background whose execution time increases exponentially each time the amount of data/forms increase(s).
Icognito mode does not solve this.

I'm sorry you're experiencing that, @Leangelindiku17! How many forms do you have on the server? How many submissions? I've seen Aggregate working with multiple hundreds of thousands of submissions but haven't used a server with many forms myself.

The server has over 100 forms with thousands of submissions.