SMTP Error: Missing credentials for “LOGIN” with gmail

Hey @yanokwa ,

I am also facing the same issue however I am using my Gmail address as SMTP services. I set up these into my config file.
Here is the screenshot of my config file

After updating the config file I entered these 3 commands
docker-compose build service
docker-compose stop service
docker-compose up -d service

I thought that if all my changes will be correct then I will be able to see port 587, into my central_mail_1 service. However, I see port 25 again, here is a screenshot


If you are using port 587, you'll need to add a secure key that is set to false. If you are using port 465, secure should be set to true.

This is documented at

Hi @yanokwa ,

Hope you are good and safe. According to your suggestion , I made changes and update part is here,
"email": {
"serviceAccount": "",
"transport": "smtp",
"transportOpts": {
"host": "",
"port": 587,
"secure": false,
"auth": {
"user": "",
"pass": "##########"

Again I am getting same error where, I am not receiving email to reset password from GUI. I am able to reset password from CLI. I also check about my 2SV(Two-Step Verification) which is off in my above email ID, still I am unable to send email for password reset.

Here is log file when I click on reset button.

And I am able to login with my user name and password which I am putting in script. I also disable Less Secure app according to this as well.


I created a new user and make admin to new user and put admin email address and password and I am able to get password reset link.