Starting Up ODK central

Hello everyone.
I just installed central everything worked well. Central started well, see screenshot below. Except that the browser tells me that the site is not accessible. I don't understand.

Here is the content of the .env file

Additional information I installed central locally on windows

What do your service and nginx container logs say?


This is what I have

According to this, your domain name doesn't map to an IP. Make sure to add an A record mapping the domain name to your server's IP.

If you've already made that mapping, you may have to wait up to a day for that change to spread across the Internet.

THANKS @yanokwa For all these guidelines I tried with Ssl_type=upstream Everything works fine I added a form And at the time of preview on enketo I have an error

"Client network Socket disconnected before secure TLS connection was established"

How to fix this problem ?


Here's what the logs say

upstream is for an HTTPS-enabled upstream reverse proxy or load balancer. It's unlikely you have that, but if you do, ask whomever set it up for help.

It's more likely that your domain name has not been mapped to your server IP. I'd recommend you try to solve that problem.

By the way I've been struggling for two weeks I want to install central locally in my company The installation goes very well but the visualization of the form with enketo always fails

I first used self-signed And I stumbled upon the error "self signed certificate" Despite all the research I have done, I have not found.

You need a fully qualified domain. That domain needs to be mapped to your server's IP. If you do not have those two things, Central will not work.

Or rather, it will not work well, and making it work well on a local network, as you have experienced, will be a complex task that will require more technical skills than most people have and more support than core team is able to provide.