Submissions Not Retrieved When Pulling from ODK Aggregate

Hi everyone! I'm hoping this is an issue others have encountered before and it's something that's easy enough to fix.

What ODK tool and version are you using? And on what device and operating system version?

ODK Briefcase v1.13.0 / HP Spectre / Windows 10 Home

What is the problem/what steps can we take to reproduce the problem?

  • I opened ODK Briefcase v1.13.0.
  • I went to the Pull tab and ensured that Pulling from: Aggregate Server is displayed.
  • I clicked Configure.
  • I entered the URL of my ODKAggregate URL, and entered my username and password.
  • NOTE: I've also gone directly to the ODKAggregate URL and logged in using the same credentials to ensure that I'm entering the correct login information.
    One form name displayed. I checked that form name (as shown in the below image) and clicked Pull.

This is where the problem occurs - I get a message that repeats for each submission:

Submission not retrieved: org.opendatakit.briefcase.util.ServerFetcher$SubmissionDownloadException: Fetch of a submission failed. Detailed error: Internal Server Error (500) while accessing:[%40version%3Dnull+and+%40uiVersion%3Dnull]%2Fdata[%40key%3Duuid%3Abc37bde6-df03-40a3-940b-d3168c6c3958]
Please verify that the URL, your user credentials and your permissions are all correct.

What you have you tried to fix the problem?

I have restarted my device, changed the ODKAggregate password, double-checked permissions, and uninstalled and reinstalled ODKBriefcase, all to no avail.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

The form I am attempting to pull has the same name as its previous iterations. I wonder if this may have some bearing on the issue, but I can't change the form name as it's already been published and had data entered into it.


Approximately how many records do you have under this form? If you are hosting your Aggregate server to AppEngine, do you have a billing account with Google? Briefcase cannot pull data from server once daily quota is over.


Hi, thanks for your response! It's only a few dozen forms, so I don't think it should hit anywhere near the daily quota.

Hi @fwashburn,

I see that you have encrypted the form. Checkout this link

Thanks @dicksonsamwel - I followed the encrypted form instructions when setting this version of the form up, so ODK Briefcase should be able to pull the encrypted forms (though I could be wrong - it wouldn't be the first time! :sweat_smile:).

Hi @fwashburn,

Since you have anonymous access for the form, you can download submission even without setting username and password. I have successfully downloaded your encrypted data. May be you have issue with the password you had set, try updating the existing user or create a new user.

Thanks again @dicksonsamwel - it's odd that there are no issues with downloading the data on your end. I just tried downloading without entering a username or password and I'm still getting the same issue. I've also tried using a different Internet network (both with my administrator login and as an anonymous user) in case it was a firewall issue, but it still isn't working.

Hi @fwashburn, a 500 error suggests that something is wrong server side, but if Dickson could pull the data, then something else is going on.

Here's what I'd try:

  1. Quit Briefcase
  2. Rename whatever your current ODK storage folder is to something else.
  3. On the command line clear your Briefcase prefs (java -jar /path/to/ODK-Briefcase-v1.12.1.jar --clear_prefs)
  4. Download the same version Dickson has from
  5. Relaunch Briefcase normally and create a new Briefcase storage folder and try again.

Hello everyone,

EDIT: Problem solved. Dowloaded v1.15.1 Briefcase; deleted all previous data stored, renamed storage folder.

I came across the same problem, and it seems to me this thread was not resolved.

I have tried @yanokwa suggested steps to fix the problem, but it remains. To me it seems it is a problem related with survey names. Namely, I uploaded a survey with the same name, delete it from Aggregate, and upload another one, with the same name, but different content.

Could it be that Briefcase is trying to dowload old survey forms, instead of new ones? Is there a way to clear all data from Brieafcase? I am using ODK Briefcase v1.12.1.

Thanks in advance.

Hi @Francisco_Carballo,

Can you see the log file? Can you attach it here?

You can do this by setting a new ODK Briefcase Storage or rename the exiting one so as briefase can create a new one in the same location

1 Like