Tableau does not recognize Central v.06 OData link

Greetings ODK friends and family,

I am quite new to ODK and have been experimenting with the newest features as I go along. I have attempted to find a response to this question everywhere, but there does not seem to be a thread on this, so this is a cry for help.

1. What is the problem? Be very detailed.

I have upgraded ODK central to the latest version (v.06), and use DigitalOcean to run it. The server holds two forms, both have media attachments (photos). One of the forms has a repeat pattern in it, the other one does not. The research team is continuing to upload data without any major issues. I am able to export one of the forms (without the repeat pattern) where the .csv file contains all data that was collected. The other form that has a repeat pattern (.zip file contains two .csv files) contains only a fraction of uploaded data - the Parent Key .csv file has all data, while the subkey .csv that has the repeat pattern and indicator containing photo does not seem to go above more than 144 entries, while there are a total of 585 photos in the media folder.

I am interested in developing a dashboard for the data being uploaded. I downloaded Tableau Public 2019.4.0 on my desktop and tried to connect it with ODK Central, by pressing on the Analyze via OData. After trying to enter the OData link from ODK Central, Tableau indicates that the file does not exist. The login credentials are for the main administrator of the server.

2. What app or server are you using and on what device and operating system? Include version numbers.

ODK Central Beta v.06, DigitalOcean

3. What you have you tried to fix the problem?

First upgraded ODK Central to Beta v.06 in order to check whether this was a bug that was identified and fixed. The missing entry issue tried to use ODK Briefcase, but it eventually exported empty forms.

For Tableau tried to use different logins, tried the WebDataConnector, different internet connections.

4. What steps can we take to reproduce the problem?

Not really sure, these issues started appearing only fairly recently. The missing data issue was first noted already with Beta v.05

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Any hints on how to even begin resolving this issue would be very much appreciated!

Hi @rsdp, and welcome to the ODK forum! When you have a chance, I'd encourage you to introduce yourself here. Doing so helps build community!

It sounds like you're running into a few issues, though I'm not sure whether they're related.

Just to check, do you expect the number of rows of data in the repeat group CSV file to be the same as the number of photos? Does the form contain only a single image field?

We just released Central v0.7, which fixes a couple of cases where the .zip download would fail. Because you're able to download the .zip file, including the photos, this sounds like it could be a different issue. However, I recommend updating to v0.7 in case that helps.

Does this mean that you were also not able to use Briefcase successfully? At which step did you encounter an issue:

  • Are you able to use Briefcase to pull the submissions from the Central server?
  • If so, are you able to export the submissions to CSV?
  • When you export to CSV for the form with the repeat group, how many rows of data does the repeat group CSV file have? (Does it have no data? Only 144 rows of data?)

Central and Tableau currently cannot communicate over OData, because Tableau deviates from the OData standard in important ways. We used to mention Tableau in the "Using OData" section, but we removed it for this reason. However, I'm noticing that we still mention Tableau in the documentation and API documentation. @issa, do you think it'd be enough to remove Tableau from the documentation? Or should we also note that Central and Tableau currently cannot communicate over OData even though Tableau seems to support OData?

@rsdp, you should have better luck with Excel, Power BI, or another tool that supports OData. Let us know if you encounter an issue while using one of those.

1 Like

Hi @Matthew_White, thank you for your comprehensive response, you are the saving grace! You are right that there are several issues - thank you for noticing.

Yes, there should be the same number of entries as photos. The teams were mapping public services, and taking photos of facilities. The team first specifies whether there are public services in a village. If present a repeat pattern initiates, where data is collected on each mapped facility.

I have upgraded ODK Central to v.07 and the issue became worse. While the parent .csv file contains all the same entries, the .csv file of the repeat group section only has 70 entries, instead of 144 before. Meanwhile, the number of media files has remained the same. The form without the repeat pattern has all entries.

Interestingly, when analyzing with OData all entries in the repeat group .csv file appear. This could be a solution to this issue, however, the incomplete .zip issue persists.

I am able to pull the submissions from the Central Server, but not able to export the submissions to CSV. Briefcase generates an empty .csv file (exported 0 submissions)

Thanks, it worked with Excel.

Glad to hear that OData is working with Excel. Hopefully we can also figure out what's happening with the .zip download and ODK Briefcase!

If you download the .zip file multiple times, is it consistently 70 rows of data? If so, is it the same data every time, or is it sometimes different data? Do you notice a pattern around what data is being downloaded (or around what data is not)? Or do you notice something about the point at which the data stops?

It'd also be very useful if you could share the logs from your server. To do so:

  1. Log into your server's command line prompt.
  2. Once you are logged into your server, navigate back to the project folder (cd central).
  3. Now download the .zip file (we want any associated errors to be the most recent log entries).
  4. Display the logs by typing docker-compose logs service

It'd also be very useful to see the log from Briefcase (its location is described here).

1 Like