The XLSForm conversion service could not be contacted

1. What is the issue? Please be detailed.

When I attempt to upload a new definition into ODK_central v1.4.2 from an xlsx file, I get the following error message:

The XLSForm conversion service could not be contacted.

2. What steps can we take to reproduce this issue?
Go to existing form in ODK central v 1.4.2 and attempt to upload new definition from xlsx document.

3. What have you tried to fix the issue?
I converted manually using the online converter. However, I noticed that it was unusually slow to complete the conversion. I also tried downloading the previous version of the form from ODK central and then uploading it as a new definition, but I get the same error.

For other forms on the same server, I was able to upload xlsx as a new definition as normal. However, if I try to upload a previously uploaded .xls version of the file I get:

The XLSForm could not be converted: Error reading .xlsx file: File is not a zip file

So it appears that xls files are no longer supported.

4. Upload any test forms, screenshots, or logs below.
Screen Shot 2022-04-11 at 2.28.28 PM

You are running into two problems.

  1. We accidentally disabled support for .xls forms in Central (issue). We will be bringing it back support for it in an upcoming release. The workaround, as you've figured out, is to save as .xslx.

  2. Your form is likely very big and your server does not have enough CPU/RAM to process it. Can you upload a copy here so we can take a look to see if there are optimizations we can suggest?

Thanks for the response. I've attached the form. Sometimes it processes on the server and sometimes it doesn't, I guess depending on server load. The server runs all other part of ODK central without issue though and is quite snappy. I can convert it to xml using the online converter and then upload that, so I don't think there are any errors in the form, just the server struggling to process it. I have processed much larger forms on the same server in the past.

UCL_Biomass_Plot_Form.xlsx (15.9 KB)

Your form has lots of blank columns and rows and seems to be corrupt in some way. The form conversion is reading through all those columns and rows and that's what is taking time.

I re-saved as XLSX in Excel 16.59 for Mac and that seems to have cleaned up the blanks. Conversion speed went from to 27.37 seconds to .43 seconds.

How did you build this form?

Ahh. I don't have excel. Maybe, Libreoffice is the culprit. It must be saving xlsx files incorrectly. That would explain why the problem is form specific and not related to even how big the form is. Thanks for your help.

In Libreoffice, I'm not able to get rid of the extra rows, but I was able to get rid of the extra columns and that seems to have made the difference. Thanks.

1 Like