Troubles with url submission between Central and Aggregate

Hi,

This post to precise the problem that @mathieubossaert began to explain to @LN two days ago...

We are actually moving some of our forms from Aggregate to Central.

To buy time and not have 5 or 6 more routines to recreate on Central I tried to fill the submission_url column with the Aggregate url in the forms "downloadable" In Central for datas to be sent to Aggregate where the good old and, above all, existing routines allow colleagues to check results of their inputs. :wink:
I made tests with at least 2 or 3 differents forms dowloaded from Central on my phone and it worked: no submission in Central and forms well visible in Aggregate.

But with colleagues now using some of thoses forms downoladed from Central for a few weeks, it seems it doesn't work any time for any forms.
It still works for at least one form, but for another one, we get the following error message when trying to send datas: "Failed to upload, make sure the form is configured to accept submissions on the server".

We made a lot of tests and check with @mathieubossaert to try to understand, without any success.
At the end, to be sure to have exactly the same forms/versions in both Central and Aggregate, we downloaded the xls form in Central, transformed it in xml using XLSForm Online V1 and uploaded it in Aggregate but the same error occured when trying to send datas.
So we tried also with a form without submission url, and this time submission (in Central) succeeded, so it seems the trouble comes from Aggregate.

Please, find attached:

  • an image from the ODK message:
  • the incriminated headache xls form with the url submission: [removed to avoid unwanted submissions]
  • another xls with the same url submission, but whose datas are correctly sent in Aggregate : [removed to avoid unwanted submissions]

Thank you very much for any explanation you can give to us. :wink:

Bonjour @nathalie_H,

I've removed the links to your forms because your server is configured such that anyone could make submissions. Even if your data is not very sensitive, you’d likely find it annoying to have to deal with spam records and risks to the server integrity.

Two ideas:

  • did you verify that both forms are open and accepting submissions on Aggregate? Even if you're confident that's the case, it's a good idea to double check.
  • I don't remember exactly how Aggregate handles different form versions. I'm not sure it accepts submissions for form versions it has never seen. For the suivis_mc_costieres_V2 form, the Aggregate server has version 20210302. The XLSForm you shared has version 20210423. I would recommend making sure that the Central and Aggregate server have the exact same form version with the same version identifier.

Bonjour @LN :slight_smile:

Thank you for the links.

Yes I checked that both forms are open and accepting submission... and I double checked after your answer. :wink:
There is an issue with form version between Central and Aggregate, for sure.
I probably get mixed up with all files we tried when I posted my question.
So, to be sure, I started all steps again: download the xls in Central, transform it in xml using XLSForm Online V1 and upload it in Aggregate... but it didn't worked.
So we'll just drop the url submission on Aggregate and send datas to Central.

Thank you for your help.

Sorry I can't solve this mystery. I'd probably need server access to figure out why submissions are rejected. If you're able to send to Central, that sounds great. You could even then pull the submissions from there and send them on to Aggregate if that lets you keep your existing analysis pipeline.