Trying to upload media files in Central but the Media tab is missing

1. What is the issue? Please be detailed.
I uploaded a survey form in Central. I see the Status and Testing tabs off to the right. There is usually a Media tab in the middle of those two tabs. I need to upload a few preloads but the Media tab is missing.

To be clear, another survey I have does show this media tab and I am able to upload to that survey. I am not sure what is different.

2. What steps can we take to reproduce this issue?
This is a good question. Screen shot is attached.

3. What have you tried to fix the issue?
I tried searching the forum for a similar issue. I tried googling the problem. I watched a video on uploading media files in ODK in YouTube.

4. Upload any test forms or screenshots below.

I am a fairly new user to ODK. I usually use SurveyCTO. Please help! Thank you!!!


Can you please share either your full form or the row that declares the media file you expect to upload? If there’s no media tab, that means Central does not see any media required by the form definition.

Thank you so much for the response LN!

I have the same code in two different surveys and one seems to recognize that there is media and the other does not.

I am attaching the file here. It is row 4 in the Excel that has the first search term for a preload.

I really appreciate your help and can answer any questions (though might be going to bed soon so maybe I might respond in the morning).

Thanks again!


Good morning @Rita_Cuckovich,

Unfortunately, you forgot an "a" in the name of the appearance column of your survey sheet. Since you are allowed to add any column you want to your xlsform, you will not be notified of the "error".



I didn't forget an "a" but clearly someone did in my project and I just never thought to check this. I totally should have because they sent me a file with a "setting" tab instead of "settings" weeks ago which I did eventually catch.

Honestly, you are really a life saver. I am not used to proofing stuff that by all rights people take from older projects so they aren't spelling themselves. It is such a weird error.

Thank you! Thank you! I looked at this a really long time today and couldn't figure it out and I have been doing SurveyCTO for 7 years (though I am new to ODK which is why maybe I didn't go back to the basics and assumed I was missing something new for ODK).

I really appreciate the help. You are amazing Mathieu.



I just already made the same mistake in the past :slight_smile: