Type Mismatch from pulldata() and date()

I've stripped down my xlsform to make it easy to replicate the issue; see attached.
pulldata_dateissue.xlsx (67.9 KB)

It seems that date(pulldata(...)) gives me a "type mismatch" error when I try to convert my xlsform here

If it is relevant, the xlsform was created with Google Drive/Google sheets and then exported as an .xslx; but this has not been an issue in the past with my other forms.

Any help on finding a workaround or a way to import a date from an external csv would be greatly appreciated!


Using the offline converter for xlsforms works for the conversion a.xml (2.3 KB), however, without the csv i can't test if the form works without crashing or having conflicts with ODK Collect.

In which format is your variable "LastCompletionDate"? I would try to import the date without using date(...), that is if you haven't tried that option yet.

I just tried the Mac OSX version of the offline converter; still getting the same error. Are you sure the Windows version works?

Ok, it seems the xlsform offline (Nafundi) download on the ODK site; at least for the Mac version, only goes up to 1.4.0. I guess Ill have to use windows for now, as the version for that converter is 1.4.7