Unable to access ODK forms in ODK collect APP on phones of android versions less than 10.0

We as an NGO and non-profit orgnisation, we collect the data using ODK collect APP on android phones and saves the submissions(data) in ODK central.
We were able to access all the ODK forms in ODK collect APP according to the given access in ODK central administration. But we have not been able to access the forms in ODK collect APP on phones which have android version less than 10.0. This has been an issue from last 3-4 months.
The ODK Collect APP is working fine on phone which have android version greater than or equal to 10.0, but not on android version of less than 10.0
Can you please suggest why this is happening and is this a universal issue?
Can you please let us know how this issue can be resolved?
I have attached the screenshot of the error that we see on ODK collect APP after we scan the QR code of the project

Welcome to the ODK forum, @Naresh_Swargam! We're glad you're here. When you get a chance, please introduce yourself on this forum thread. I'd also encourage you to add a picture as your avatar because it helps build community!

I'm sorry to hear you are having this problem. Collect should be backward compatible with much older versions of Android than what you mention. Please answer some additional questions to help troubleshoot.

  1. What is the Collect version that is running on the phones with the error?
  2. What is you version of Central? (You add /version.txt to the end of your URL to find this. For example: https://myCentralServer.org/version.txt)
  3. You say Android version less than 10. What version of Android?
  4. The icon to the right of "Start new form" shows a sync error. Are there any error messages that you are shown in the app?
  5. Are the phones with the errors on the same network for internet access? Are they able to go to websites and use other apps that require an internet connection?
1 Like

It's not a universal issue because we have a lot of users using Android versions below 10 and QA tests with versions below Android 10.

Are you absolutely sure that the app user QR code that you're scanning from Central has forms assigned to it in Central?

Are you seeing this issue with a single Android devices or many Android devices?

Did anything change or happen 3-4 months ago on your project or server or devices?

Hi Yanokwa, thanks for your response.
ODK forms are not accessible on phones which have android versions less than 10 that means 9, 8, etc… it is working fine on 10 and greater than 10 versions.

Yes I am 100% sure that the app user QR code that I am scanning from Central has forms assigned to it in Central.

We also have tried with many android phones and we have come to coclusion after checking on multiple devices that android versions which are less than 10 are no longer supporting ODK collect forms

The same forms are accessible on android phones which have version 10 or greater than 10.

Nothig has changed on the server and devices in the last 3-4 months. Forms used to be working fine on all the android phone 3-4 months ago.

Thanks for your response Joseph,
--> Android version: 8.0.0
--> ODK Collect APP version: V2023.2.3
--> ODK central version: 474f008e3f9805aa762041c5fc124464b7239cd3 (v1.5.2-1-g474f008)
3078965dc8ad86b34944476d0dd84475487d44ab client (v1.5.2)
12568c504151c919b11c9962dd3ef866cebbd0e7 server (v1.5.1)
--> I can't see any error on the ODK collect APP which causes sync issue.
--> We have tried with multiple phones from multiple locations and we tried using mobile data and WiFi networks. But we have noticed the issue still persists.

I don't think this is the cause of the issue but... ODK Central v1.5.2 was released July 12, 2022. There have been several releases since then that have fixed a variety of bugs. We recommend you upgrade to v2023.3.1 so that you have all the fixes, security updates, and new functionality. Please carefully read through the instructions on https://docs.getodk.org/central-upgrade/ especially the "Version-specific upgrade instructions" as there are some extra considerations for some of the upgrades.

This is the icon showing an error syncing:
Screenshot 2023-08-29 at 8.45.27 PM

When there is no problem, there should be no exclamation mark and when you click it there will be "Form update succeeded" message displayed at the bottom of the screen:

When you click the icon, does a status message display at the bottom of the screen?

If you go to the project settings and then server settings do you see a URL for your server that includes a long token (string of letters and numbers)?

In the server settings of ODK collect app, I can see a URL for your server that includes a long token. See below screenshot.

But exclamation mark is still there on "start new form" page on the App.
Can you please confirm if upgrading ODK central is the only option we have, to get all the related forms accessible in ODK collect app on all android mobiles?

Hello Naresh,

We faced this issue on some of our phones a few days ago.

We tried 2 things

  1. Some phones had this issue because of low network connectivity, we switched to another network and issue got resolved
  2. On some devices we had to uninstall the ODK Collect and reinstall again to resolve this synchronisation error.

This worked for us

1 Like

@Naresh_Swargam, I'm sorry you're running into this issue. Are there any new forms that you might have deployed around when it stopped working? Maybe with a form feature you haven't used before? Can you try an App User that only has access to one very simple form?

When sync fails, you should generally get a notification with more details about the error. Can you swipe down from the top of your device and see whether there are any Collect notifications there?

Thanks for sharing your experience, @Nikhil_Nikam!

This is very surprising to me. Did you get a notification with more details about the error? I can't currently think of a reason that reinstalling would help unless maybe your device storage had gotten corrupt in some way. You said it happened on multiple devices at once? And was it also on Android versions less than 10?

1 Like

Hi @Nikhil_Nikam, thanks for your response. Before posting this issue in forum, we already tried the steps multiple times you mentioned above. However it didn't resolve the issue.

Hi @LN , we have around 35 projects in our ODK central. Total 8 forms were deployed on the project in which we are experiencing the issue. 7 forms were deployed long back in 2021 or 2022, however one form was deployed on 05/04/2023. I am really not sure how the deployment of this new form is causing the issue.
As you suggested, I have created a simple new form with only four questions and deployed into the same project. I have created a new user and access has been given to only this form. For the same user, the form is accessible on phone which has android version of 12 and it is not accessible on phone which has version 7.1.1
Hence the simple form is also not working on android which is less than 10.0

I also tried to click the refresh the button which has exclamation mark and I received a notification of "Form update failed" with the details shown in the below screenshot.

Thanks for sending the screenshot. The “can’t connect securely” message means it’s an SSL issue.

You mentioned Android 7.1.1. What is the device make and model you used? Did you use any other Android versions and makes and models?

Please send me the QR code for your simple project as a direct message so I can investigate further.

1 Like

Hi @LN , I just wanted to let you know that we have tried by deploying the same simple form in another project on the same server. The form is still not accessible on android version 7.1.1
Device Name : OPPO A83
Model: CPH1729
I will try on other android mobile phones which have android version less than 10 and send you the details.

Can you please help me with your email ID, so that I can send the QR code of simple form.

1 Like

@Naresh_Swargam, you can click LN's profile image and then click "Message" to send a direct message.

1 Like

Hi @danbjoseph , I can't see message or chat option after I click @LN 's profile.

Hi @LN , I have also tried on another android phone of version 9. The form is not accessible on this phone too.
Device name: Redmi 6 Pro
Android version: 9

Hi @danbjoseph , do I have any other option to send a direct message to @LN as I can't see any message or chat option after I click @LN 's profile.

I’ve bumped your forum access so you should now be able to message. If that still doesn’t work, send the files to support@getodk.org.

Thanks for sending me that QR code, @Naresh_Swargam. I'm sorry it took some work, I didn't realize you wouldn't have the ability to send direct messages yet! Welcome to the community and hopefully we can get this resolved quickly.

By debugging Collect, I see the full error:

routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

This means your server does not support any TLS version that older Android versions support. Specifically, by running an SSL server test at https://www.ssllabs.com/ssltest/index.html, I see that your server only supports TLS 1.3.

If you do need to support older Android devices, you will need to support TLS 1.2. It likely got disabled 3-4 months ago because of a policy change. You'll have to look into how to re-enable it for however nginx is configured and/or your network is set up. The recommended/default Central nginx config is here: https://github.com/getodk/central/blob/f09c50bc3cd7537545916c25b792079c072a6ae1/files/nginx/odk.conf.template#L9

1 Like

Thanks a ton for your help @LN, @yanokwa and @danbjoseph . Issue has been resolved now. We have changed the compatibility of TLS from Modern to Old backward.