Unable to add or modify password to users

I have downloaded the VM of ODK, and configured debian to work in my network.
I access ODK Aggregate by typing in the address bar of the browser the virtual machine IP (
Everything works fine. I can log-in with the default super-user password, "aggregate"

But when I try to add new users and setting them a password or changing the superuser password, I get an error from the JSON request:
JSON change-password request to failed

Inspecting the network traffic I can see that the response from
ht tp:// aggregateui/ securityservice is:
//OK[5,0,4,0,3,2,1,["org.opendatakit.common.security.client.RealmSecurityInfo/2535212060","SHA-1","","ODK Aggregate VM","administrator"],0,7]

The new users obviously don't work without a password, so now I'm pretty limited.
Please note that this is not a production environment but only a demo/test service, so I can't install an SSL and the IP address could change.

Thanks for the help!!

Please!! no one knows how to solve this issue??

Please help me!

Hi @chiara! I just tried the changing the password using the Configure Site Access in my Aggregate v1.5 VM and it worked great for me.

I logged into Aggregate, then under Site Admin -> Preferences, added a test user in the Add Users section, it Save Changes, then hit Change Password to set the password. Are you following the same set of steps?

Thanks Yaw,

Yes, I'm following the exact same steps you told me.
And I'm running the VM exactly as I have downloaded I've not made any changes to it that should have compromised the ODK installation.

Hmm. Strange. If there is no data on the VM, let's try this. Delete it, download a new one, and don't change the networking. Then try to change the password in that VM. Does that work?

Also, what version of Virtualbox are you using and on what guest OS?

I'm using virtual box 5.2.8 on Windows 10, network is set to Bridged Adapter.

I'll try to download and run again the VM and let you know, thanks

1 Like

I was getting the same error when changing the web user's password, but running the aggregate-config script fixed it for me. See step 4 of https://docs.opendatakit.org/aggregate-vm/#connecting-to-the-vm-from-external-apps.

The exact command I ran was aggregate-config --fqdn auto --http-port 80.

From my rush through the error messages in the browser console, it seemed as though the site had a problem calling the user-manage-passwords script on the default port 10080 when I was browsing to the site on port 80 (and browsing to the site on 10080 failed with an 'unable to connect' error).

You mention port 8080 so it looks like you have already ran that command, but it doesn't look like you access the page on port 8080 (since you 'access ODK Aggregate by typing in the address...'), so you have the same difference, between the port used to open the page and the port being used when the script is called, as I did.


Hi, @chiara! Did you try using a new VM without changing any networking settings? Once we can establish that a factory default VM works, we can proceed to change networking settings to set it up like you want in your scenario. @r4mzy has pointed out the generic procedure for that in his comment.

@r4mzy thank you soooo much!! I've given me the right direction to solve the issue
I was accessing the aggregate site on port 8080 as I've run the cmd
aggregate-config --fqdn auto --http-port 8080

but the request starting from the site was not updated to match the port, so they went through 80.
Setting everything on port 80
aggregate-config --fqdn auto --http-port 80
solves the issue.

I'm only wondering what I should do to set it on a different port...

Thanks to all.

1 Like

Hey hi @r4mzy

Im also facing the same issue. Can you please help and understand how and where to run this command on windows server 2008.


@usfreak13 That command only applies in the VM.

1 Like

Thanks Yanokwa for the info.

I updated my version to 2.0.2 and it works like a cheese cake on windows server 2008 R2.

Thanks @chiara @r4mzy @ggalmazor for fruitful disucssion.


1 Like